Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Atechsystem

1
Raspberry PI / MLD auf Raspi ohne "shutdown"?
« on: August 15, 2019, 18:39:35 »
Im Log ist zu sehen, dass mehrere wichtige Dateien leer sind. Unter anderem sind die zentrale Configurations-Datei und die VDR Kanalliste betroffen.
Die einfachste Lösung dürfte sein einen Snapshot zurück zu gehen. Das geht z.B. im Webinterface Setup unter "Snapshots".

Danke für den Tipp, ich spiele einfach das gesicherte Image zurück, aber mit der von dir beschriebenen Methode geht es sicher schneller. Bin trotzdem Überrascht, dass das System so zerschossen wird.

2
Hallo miteinander, Hallo Claus,

Ich schreibe noch mal einen extra Thread, da ich das Thema bisher nur im VDR Portal diskutiert habe und es evtl. untergegangen ist. Der zugehörige Thread im Portal:

https://www.vdr-portal.de/forum/index.php?thread/132383-hilfe-gesucht-mld-5-x-mit-der-tt-connect-s2-3650-ci/&pageNo=1

Die Frage ist, ob der Patch für die TT3600/3650 auch für den Pi eingebunden ist? Ich habe unter gewissen Umständen immer wieder die Artefakte, die ohne den Patch typischerweise auftreten.

Wie in dem verlinkten Thread zu lesen ist ist er wohl ab Kernel 4.7 offiziell mit dabei. In jedem Fall noch einmal Danke, dass er bereits in MLD übernommen wurde!

Gruß
Atech

3
Raspberry PI / MLD auf Raspi ohne "shutdown"?
« on: August 15, 2019, 11:01:45 »
Normalerweise ist es kein Problem eine MLD einfach hart auszuschalten. Es wird jedoch gelegentlich berichtet das dies beim einem RPI Probleme macht. Ich vermute das es mit der verwendeten SD-Karte zusammen hängt. Hast Du's schon mal mit einer SD-Karte von einem anderen Hersteller versucht?

Ich verwende die typische rote Sandisk, die parallel auch in meinem Raspit für Ambilight werkelt. Dort habe ich keine Probleme. Aber wenn du einen Tipp hast, welche ich kaufen soll probiere ich es liebend gerne aus  :)

4
Raspberry PI / MLD auf Raspi ohne "shutdown"?
« on: August 15, 2019, 11:00:02 »
Hast du an deiner MLD eine Fernbedienung oder Tastatur dran? Wenn ja wieso schaltest du sie nicht normal ab und dann nimmst du ihm den Strom? Habe hier eine MLD am Rpi laufen den schalte ich normal mit der Power OFF Taste der FB aus und dann schalte ich den Strom ab über den Sonoff 4CH wo er dran hängt. Beim nächsten mal wenn ich ihm wieder Strom gebe fährt er normal hoch.

Den "SonOff" kannte ich noch garnicht. Interessant, aber ich möchte eine ganz einfache und stupide Lösung finden. Ohne Programmieren oder irgendwelche Timer. Das hat mich in der Vergangenheit immer viel Arbeit gekostet und dann am Ende nie richtig funktioniert ;)

Habe schon versucht das mit meiner Logitech irgendwie zu Programmieren, ist aber unzuverlässig - was mich in meiner obigen Aussage wiederum bestätigt.

5
Raspberry PI / MLD auf Raspi ohne "shutdown"?
« on: August 15, 2019, 10:54:45 »
Daß MLD auf den Raspi nach einem "Stromausfall" dann nicht mehr funktioniert, ist mir auch schon passiert.
Nach der Installation von suspend lasse ich den Raspi einfach laufen. Der VDR wacht für eine geplante Aufnahme auf und schaltet sich dann wieder ab.
Stromverbrauch im suspend Modus: ca. vier Watt.
Im suspend Modus kann ich auch jederzeit die Spannungsversorgung wegnehmen - MLD-VDR funktioniert dann auch immer wieder - sehr oft probiert.

Aufnahmen sind für mich nur noch im Sinne von Zeitversetztem TV interessant. Daher muss der Raspi nicht laufen wenn er nicht mehr benötigt wird. Hinzu kommt, dass meine USB TV Karten einfach nicht in den suspend schalten und sinnlos zu viel Strom verbrauchen.

6
Raspberry PI / MLD auf Raspi ohne "shutdown"?
« on: August 15, 2019, 10:51:37 »
Hallo miteinander,

habe eure Antworten jetzt erst gesehen, vielen Dank schon mal dafür.

Ich dachte ich bekomme eine Email falls es Neuigkeiten gibt. Muss wohl mal meine Benachrichtigungseinstellungen überprüfen.

Zu dem Problem an sich, es ist heute wieder aufgetreten:

/var/log/vdr:
Code: [Select]
Slot 1: reset...ok.
Slot 1: no module present
Magick: abort due to signal 11 (SIGSEGV) "Segmentation Fault"...
Aborted
VDR exits at So Aug 11 17:29:02 CEST 2019
Slot 1: reset...ok.
Slot 1: no module present
Magick: abort due to signal 11 (SIGSEGV) "Segmentation Fault"...
Aborted
VDR exits at So Aug 11 17:29:12 CEST 2019
Slot 1: reset...ok.
Slot 1: no module present

/var/log/x
Code: [Select]
X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.41-v7+ armv7l Raspbian
Current Operating System: Linux (none) 4.20.7.201.11 #1 SMP Sun Feb 17 20:26:39 UTC 2019 armv7l
Kernel command line: 8250.nr_uarts=0 bcm2708_fb.fbwidth=1920 bcm2708_fb.fbheight=984 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  root=UUID=8f30a552-c769-451c-943a-a2768e168df6 splash=silent quiet nodialog smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 dwc_otg.fiq_enable=0 dwc_otg.fiq_fsm_enable=0
Build Date: 18 October 2017  04:55:30PM
xorg-server 2:1.19.2-1+rpt1+deb9u2 (https://www.debian.org/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 11 17:28:32 2019
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
icewm-session: using /root/.icewm for private configuration files
icewmbg: using /root/.icewm for private configuration files
IceWM: using /root/.icewm for private configuration files
IceWM: Warning: Could not load fontset "-artwiz-snap-regular-r-normal-sans-10-*-*-*-*-*-*-*".
IceWM: Warning: Missing codesets for fontset "-artwiz-snap-regular-r-normal-sans-10-*-*-*-*-*-*-*":
IceWM: Warning:   ISO8859-2
IceWM: Warning:   ISO8859-3
IceWM: Warning:   ISO8859-4
IceWM: Warning:   ISO8859-5
IceWM: Warning:   KOI8-R
IceWM: Warning:   ISO8859-7
IceWM: Warning:   ISO8859-9
IceWM: Warning:   ISO8859-13
IceWM: Warning:   ISO8859-14
IceWM: Warning:   ISO8859-15
IceWM: Warning:   JISX0208.1983-0
IceWM: Warning:   KSC5601.1987-0
IceWM: Warning:   GB2312.1980-0
IceWM: Warning:   JISX0201.1976-0
IceWM: Warning:   ISO10646-1
IceWM: Warning: Could not load fontset "-artwiz-snap-regular-r-normal-sans-10-*-*-*-*-*-*-*".
IceWM: Warning: Missing codesets for fontset "-artwiz-snap-regular-r-normal-sans-10-*-*-*-*-*-*-*":
IceWM: Warning:   ISO8859-2
IceWM: Warning:   ISO8859-3
IceWM: Warning:   ISO8859-4
IceWM: Warning:   ISO8859-5
IceWM: Warning:   KOI8-R
IceWM: Warning:   ISO8859-7
IceWM: Warning:   ISO8859-9
IceWM: Warning:   ISO8859-13
IceWM: Warning:   ISO8859-14
IceWM: Warning:   ISO8859-15
IceWM: Warning:   JISX0208.1983-0

/var/log/Xorg.0.log: Keine Auffälligkeiten

/var/log/messages: Leer

/var/log/sysinit: Leer

Im Bereich "Pakete" werden mir folgende Meldungen angezeigt:

Code: [Select]
E: Malformed entry 2 in list file /etc/apt/sources.list.d/main.list (Component) E: The list of sources could not be read. E: Malformed entry 2 in list file /etc/apt/sources.list.d/main.list (Component) E: The list of sources could not be read.

Keine Aktualisierungen verfügbar.

Habe ein "debug_log" angehangen, auffällig dabei die Systemzeit und Datum stimmt nicht.

Gruß
Atech

7
Raspberry PI / MLD auf Raspi ohne "shutdown"?
« on: July 31, 2019, 15:01:35 »
Hallo miteinander,

verwendet von euch jemand MLD auf dem Raspi ohne das er das System ordnungsgemäß herunterfährt?

Ich mache das mit vielen Raspis, aber MLD habe ich damit jetzt schon zwei mal abgeschossen. Musste mein gesichertes Image neu aufspielen damit es wieder läuft.

Ich verwende den Raspi an einer Master/Slave Steckdose. Er bekommt das Ausschalten des Systems also nicht mit. Habe schon an eine PiUSV Lösung oder ähnliches gedacht.

Bin für alle Ideen zu haben.

Gruß
Atech

8
Hallo miteinander,

ich habe ein seltsames Problem mit der Harmony Tastatur. Es funktionieren nur die Nummerntasten. Alles andere wie z.B. das Mauspad, geht leider nicht.

Eine kurze Beschreibung der Harmony Tastatur:

Eigentlich ist sie baugleich zur K400i von Logitech, die ich auch besitze. Die Tastatur wird allerdings mit dem Harmony Hub verbunden und dann automatisch an den Empfänger gesendet, der grade innerhalb der Fernbedienung aktiv ist. Dazu kann man den Rechner mit BT koppeln oder auch die beigelegten USB Empfänger verwenden. In meinem Fall nehme ich den zugehörigen USB Empfänger, der sich normalerweise genauso verhält wie ein normaler Logitech Unifying Empfänger.

Bisher hatte ich damit keinerlei Probleme. Aber mit dem Empfänger funktionieren wie gesagt bei meinem Raspi nur die Nummerntasten, Ich vermute, die Tastatur wird als Fernbedienung eingebunden. Besonders seltsam ist, dass meine Logitech K400i diese Probleme nicht zeigt.

Xorg log habe ich Angehangen. Bin für alle Ideen Dankbar.

Gruß
Atech