1 ... 12 13 [14] 15 16 ... 27 >>> Archiv / MLD 3.x / Raspberry PI / Raspberry Pi
 

Offline Uwe

  • Adv. Member
  • ***
  • Posts: 144
    • View Profile
Raspberry Pi
« Reply #195 on: September 07, 2012, 10:25:03 »
Quote
magst Du mal das client-vomp Image testen, ob das mit Deinem VDR-Server zusammen arbeitet?
Moin Claus,
ja mache ich sehr gerne. Leider wird das vor morgen Abend nix.
Ich habe ebend schon mal kurz geschaut, welche Meldungen ich beim start vom vompclient finde.... aber ich finde dazu nichts. Ich muß mir mal anschauen, wie man den vompclient dazu bekommt, ein logfile anzulegen....

Bis Morgen.... Gruß Uwe
« Last Edit: September 07, 2012, 10:25:48 by Uwe »

Offline Rudi

  • Newbie
  • *
  • Posts: 24
    • View Profile
Raspberry Pi
« Reply #196 on: September 07, 2012, 11:25:36 »
Hi Claus!

Bei mir sieht es mit dem standard-vomp so aus, als hätte der vompserver keine Berechtigung oder Möglichkeit, sein UDP-Socket aufzumachen. Damit hat der Client dann natürlich auch nichts zum Verbinden.

Code: [Select]
01:01:41.639501 [info]   Main - Logging started
01:01:41.642681 [CRIT]   UDP - Bind error 3024
01:01:41.643452 [CRIT]   Main - Could not start UDP replier
01:01:41.643953 [info]   Main - Stopped main server thread
01:02:59.828857 [info]   Main - Logging started
01:02:59.830748 [CRIT]   UDP - Bind error 3024
01:02:59.831323 [CRIT]   Main - Could not start UDP replier
01:02:59.831741 [info]   Main - Stopped main server thread
01:04:17.086333 [info]   Main - Logging started
01:04:17.087998 [CRIT]   UDP - Bind error 3024
01:04:17.088567 [CRIT]   Main - Could not start UDP replier
01:04:17.088967 [info]   Main - Stopped main server thread

EDIT: Hab noch ein Bisschen rumprobiert. Wenn der VDR neu gestartet wird, scheint der vompserver weiter zu kommen. Der Client scheint auch mit ihm zu reden; zumindest meldet er "Connection lost", wenn ich den VDR abschieße.
Was ich auffällig finde, ist, dass der VDR auch per svdrpsend keine Kanalwechsel schafft. Da bekomme ich nur "Error switching to channel 441" oder dergleichen. Vielleicht ist der Server das Problem.

Die mögliche Lösung mit XINE klingt für mich auch vielversprechend. Bin mal gespannt...
« Last Edit: September 07, 2012, 11:41:52 by Rudi »

Offline umaar

  • Newbie
  • *
  • Posts: 17
    • View Profile
Raspberry Pi
« Reply #197 on: September 07, 2012, 11:28:28 »
Hab mir auch mal das client-vomp Image gezogen und auf meinen yavdr Server das Plugin installiert. Erhalte auch nur die Meldung "connecting to vdr". Am yavdr-Server ist im Vomp Verzeichnis eine leere .conf Datei erstellt worden mit der MAC Adresse des Raspberry. Startet der Server neu bekomme ich am Raspberry sofort "connection lost".
« Last Edit: September 07, 2012, 11:47:13 by umaar »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #198 on: September 07, 2012, 17:09:08 »
Ich hab nun erst mal den vomp-server der MLD auf den neusten Stand gebracht.
Beim Client habe ich nur ne Kleinigkeit geändert. Sofern Lokal nen VDR läuft (standart-vomp) wird dem vompclient nen Parameter mitgegeben damit der nicht nach dem Server suchen muss.

umaars test Ergebnis verwundert mich allerdings. Ich hätte erwartet das der vompclient sich mit einem nicht-MLD Server verbinden kann, da Uwe das ja bereits erfolgreich (mit raspian) machen konnte, und ich die neusten vompclient Sourcen genommen habe.

@Uwe,
Mit was für nem System als vompserver hattest Du Deinen erfolgreichen Test durchgeführt? Wo hast Du den vompclient für raspian her bekommen?

Mit dem neuen vompclient Addon kannst Du in der rc.config den Parameter VOMPCLIENT_ARGS="-d" hinzufügen. Dann werden in der Datei /var/log/vompclient die Debugmeldungen geloggt.
Auf der Komandozeile geht das dann per "runvompclient".
Alternativ kann auch "vompclient -n -d" aufgerufen werden. Beendet werden kann das dann nur per "killall -9 vompclient".

Claus
« Last Edit: September 07, 2012, 17:14:22 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Andy

  • Profi Member
  • ****
  • Posts: 393
  • Windows is great! I used it to download Linux.
    • View Profile
Raspberry Pi
« Reply #199 on: September 07, 2012, 19:55:09 »
Hallo
Na, suuuper  meiner kommt erst in 12 Wochen....hoffe ich platze nicht vorher....bin jetzt doch ein bisschen ungeduldig. :))

....und ich hoffe da kommt nicht noch mehr dazu...Raspberry behebt kleine Fehler

MFG
Andre
Meine VDR's (show / hide)

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #200 on: September 08, 2012, 03:47:01 »
Ich hab's nun endlich hin bekommen, dass der vompclient startet. Dafür musste ich den ein klein wenig verändern. Der Client sendet normalerweise während des Logins am Server noch ne zweite Anfrage parallel dazu, was dem Server gar nicht gefällt. Als Hotfix habe ich die Zweite Anfrage komplett entfernt.
Somit bekomme ich nun schon mal das Menü auf den Schirm. Da z.Z. meine Tastatur unter X nicht funktioniert, komme ich nun aber nicht weiter, bzw. ich hab noch keine Ahnung wie man den überhaupt per Tastatur steuern kann, da der sich ja auch ohne nen xserver starten lässt, also überhaupt kein Fenster hat, das den Fokus bekommen kann.
Wenn da jemand ne gute Idee zu hat, immer raus damit ;)

@Uwe,
wie Steuerst Du deinen vompclient unter raspian?

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline MarMic

  • Administrator
  • Expert Member
  • ********
  • Posts: 4811
    • View Profile
Raspberry Pi
« Reply #201 on: September 08, 2012, 10:35:13 »
@claus nicht mit xkeysym oder wie das heisst sondern mit den gleichen tasten wie ganz am anfang der vdr bedient wurde.

war das keyboard.*

also nicht das frontend steuern sondern direkt den vdr (wie halkt früher)

 
SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - DVBSky S952 - Astra 19,2 - MLD 5.4

WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLD 5.4


Offline skippy

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2157
    • View Profile
Raspberry Pi
« Reply #202 on: September 08, 2012, 10:55:44 »
Quote
war das keyboard.*
meinst du diese Sachen aus der remote.conf?
Code: [Select]
KBD.Red        000000001B5B5B41
KBD.Green      000000001B5B5B42
KBD.Yellow     000000001B5B5B43
KBD.Blue       000000001B5B5B44
KBD.0          0000000000000030
KBD.1          0000000000000031
....
Das ist bei mir heute noch aktiv. Wenn die Fernbedienung oder die MLD mal nicht so will, nutze ich die auch heute noch. Ist das nicht mehr Standard?

Viele Grüße skippy
meine MLDs (show / hide)

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #203 on: September 08, 2012, 11:24:15 »
Nur wo soll ich die Testenereignisse hin schicken. Der vompclient startet normalerweise als deamon, und auch wenn man das unterbindet, so nimmt der Keine Eingaben eintgegen. Die werden einfach auf der Konsole ausgegeben.

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Uwe

  • Adv. Member
  • ***
  • Posts: 144
    • View Profile
Raspberry Pi
« Reply #204 on: September 08, 2012, 11:29:39 »
Quote
@Uwe,
Mit was für nem System als vompserver hattest Du Deinen erfolgreichen Test durchgeführt? Wo hast Du den vompclient für raspian her bekommen?

Mit dem neuen vompclient Addon kannst Du in der rc.config den Parameter VOMPCLIENT_ARGS="-d" hinzufügen. Dann werden in der Datei /var/log/vompclient die Debugmeldungen geloggt.
Auf der Komandozeile geht das dann per "runvompclient".
Alternativ kann auch "vompclient -n -d" aufgerufen werden. Beendet werden kann das dann nur per "killall -9 vompclient".
Moin Claus,
der Server läuft auf einem gen2vdr-v3 mit vdr-1.7.29 und dem vompserver plugin aus dem git.
Ich habe raspbian immer wieder erweitert und aktualisiere das System mit apt-get update && apt-get upgrade. Den Kernel und die Firmware aktualisiere ich mit dem Tool rpi-update.
Den vompclient für den raspbian habe mir als git gezogen und auf der Himbeere gebaut. Von hier.

Edit: irgendwo steht (vompforum), dass man den Speicher (memory-split) auf 128MB einstellen sollte.

Die Optionen teste ich heute Abend, Danke für den Tipp. :)

Gruß Uwe
« Last Edit: September 08, 2012, 11:39:17 by Uwe »

Offline Uwe

  • Adv. Member
  • ***
  • Posts: 144
    • View Profile
Raspberry Pi
« Reply #205 on: September 08, 2012, 11:33:20 »
Quote
@Uwe,
wie Steuerst Du deinen vompclient unter raspian?
Ich logge mich als root ein und starte den vompclient direkt in der Konsole. Dann kann ich mit der Tastatur den Vompclient steuern.
Das Problem ist teilweise nur, das man im Hintergrund die Bash Befehle abarbeitet.... aber für erste Tests reicht das erstmal. ;) Unter X habe ich das noch nicht getestet.

Gruß Uwe
« Last Edit: September 08, 2012, 11:35:23 by Uwe »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #206 on: September 08, 2012, 14:16:05 »
So, ich hab nun herausgefunden, wie der vompclient gesteuert wird. Der liest einfach alle event devices. Da jedoch nen Fehler in der Kernel Konfiguration war, wurden keine event Devices erstellt. Z.Z. lasse ich nen neuen Kernel bauen. Mit dem wird sich dann auch der vompclient steuern lassen.
Nen TV Bild habe ich trotzdem nicht bekommen. Da werde ich wohl noch ein wenig Ursachenforschung betreiben müssen. Ich habe zwar noch keine mpeg2 Lizenz, aber HDTV sollte ja trotzdem gehen.
Es wird also nachher neue Images geben.

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Uwe

  • Adv. Member
  • ***
  • Posts: 144
    • View Profile
Raspberry Pi
« Reply #207 on: September 08, 2012, 19:47:25 »
Quote
Es wird also nachher neue Images geben.
Das werde ich dann testen! :)
Vielen Dank.

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #208 on: September 08, 2012, 22:46:55 »
Hi,

die letzten Images waren leider unbrauchbar. Ich nehme die wieder vom Server und packe später (wenn sie fertig sind) neue da drauf.

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline umaar

  • Newbie
  • *
  • Posts: 17
    • View Profile
Raspberry Pi
« Reply #209 on: September 08, 2012, 22:52:58 »
Hallo claus,

erst mal muss ich mich nochmals für die super Arbeit bedanken  :applaus

Hab mir vorhin das vomp-client Image gezogen und getestet.
+ Verbindung zum Server funktioniert jetzt super
+ Steuerung geht nun auch über die Tastatur
+/- SD-Kanäle laufen (hab ne MPEG2 Lizenz) / es gibt jedoch "Mikroruckler" und meine Deinterlacing geht noch nicht
+Umschaltzeiten sind schnell
- HD Ruckelt bzw. geht zum Teil garnicht
- von HD auf SD ohne Overclocking (arm 840; core 375) nicht möglich (bleibt hängen und Stromreset muss durchgeführt werden)
- sobald Webinterface aufgerufen wird ruckelt die Raspberry Wiedergabe sehr stark

So das war´s was ich auf die schnelle herausgefunden habe.  ;)  Jetzt gibts aber erst mal Boxen :-P

Vg

[EDIT] claus hab gerade deine Nachricht gelesen ;-)
« Last Edit: September 08, 2012, 22:58:22 by umaar »

1 ... 12 13 [14] 15 16 ... 27 >>> Archiv / MLD 3.x / Raspberry PI / Raspberry Pi
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.