1 ... 10 11 [12] 13 14 ... 27 >>> Archiv / MLD 3.x / Raspberry PI / Raspberry Pi
 

Offline glotzi

  • Newbie
  • *
  • Posts: 11
    • View Profile
Raspberry Pi
« Reply #165 on: September 03, 2012, 12:47:57 »
Wäre ist nicht sinnvoller den Crosscompiler zu nehmen?

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #166 on: September 03, 2012, 13:33:39 »
Schneller wäre das schon, jedoch harmoniert das nicht mit der Art wie die MLD Pakete zusammen gebaut werden. Bei der MLD werden beim bauen von Addons alle benötigten libs automatisch zum Addon hinzugefügt, sofern die nicht bereits in einem abhängigen Addon enthalten sind. Das lässt sich nur schwer auf ne crosscompiler Umgebung übertragen.

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #167 on: September 03, 2012, 13:44:49 »
Ich hab nun korrigierte Images online gestellt.
Ich bin jedoch nicht sicher wie weit sich der Fehler fortsetzt, also ob noch weitere Addons davon betroffen sind. Somit werde ich heute Abend einen kompletten Rebuild anstoßen.
Mit etwas Glück funktionieren die neuen Images aber bereits wieder.

Claus


EDIT: Ups, ich sehe grad, das die neuen Images wohl auch noch nicht gehen werden, da war mir noch nen Fehler unterlaufen. Es wird also in 10 Minuten noch nen Update geben...
« Last Edit: September 03, 2012, 13:46:22 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #168 on: September 03, 2012, 14:50:39 »
Die neuen Images sind nun fertig.

Claus
« Last Edit: September 03, 2012, 14:50:48 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline umaar

  • Newbie
  • *
  • Posts: 17
    • View Profile
Raspberry Pi
« Reply #169 on: September 03, 2012, 17:35:24 »
Hallo clausmuus,

vielen danke für die super Arbeit :D

Bekomme jetzt schon mal ein BILD also wirklich nur eins :lol:  nach ca. 2 Min Boot-Zeit kommt der erste sender (N24 SD) und das Bild bleibt stehen. Webserver reagiert auch nicht mehr.
MPEG2 Lizenz ist in der config.txt eingetragen.

Mein yavdr Server meldet
Quote
Sep  3 17:27:32 sat mountd[1422]: refused mount request from 192.168.2.102 for /mnt/data (/): not exported
Sep  3 17:29:04 sat vdr: [1966] Streamdev: Accepted new client (VTP) 192.168.2.102:59134
Sep  3 17:29:04 sat vdr: [1966] Streamdev: Setting data connection to 192.168.2.102:55512
Sep  3 17:29:04 sat vdr: [2362] streamdev-writer thread started (pid=1689, tid=2362)
Sep  3 17:29:04 sat vdr: [2363] streamdev-filterstreaming thread started (pid=1689, tid=2363)
Sep  3 17:29:04 sat vdr: [1966] Streamdev: Setting data connection to 192.168.2.102:56275
Sep  3 17:29:04 sat vdr: [2364] streamdev-writer thread started (pid=1689, tid=2364)
Sep  3 17:29:04 sat vdr: [2365] streamdev-livestreaming thread started (pid=1689, tid=2365)
Sep  3 17:29:04 sat vdr: [2366] receiver on device 2 thread started (pid=1689, tid=2366)
Sep  3 17:29:04 sat vdr: [2367] TS buffer on device 2 thread started (pid=1689, tid=2367)
Sep  3 17:29:19 sat vdr: [2365] streamdev-livestreaming thread ended (pid=1689, tid=2365)
Sep  3 17:29:19 sat vdr: [2364] streamdev-writer thread ended (pid=1689, tid=2364)
Sep  3 17:29:19 sat vdr: [1966] buffer stats: 1155072 (30%) used
Sep  3 17:29:19 sat vdr: [2367] TS buffer on device 2 thread ended (pid=1689, tid=2367)
Sep  3 17:29:19 sat vdr: [2366] buffer stats: 71816 (1%) used
Sep  3 17:29:19 sat vdr: [2366] receiver on device 2 thread ended (pid=1689, tid=2366)
Sep  3 17:29:19 sat vdr: [1966] Streamdev: Setting data connection to 192.168.2.102:43196
Sep  3 17:29:19 sat vdr: [2368] streamdev-writer thread started (pid=1689, tid=2368)
Sep  3 17:29:19 sat vdr: [2370] receiver on device 2 thread started (pid=1689, tid=2370)
Sep  3 17:29:19 sat vdr: [2371] TS buffer on device 2 thread started (pid=1689, tid=2371)
Sep  3 17:29:19 sat vdr: [2369] streamdev-livestreaming thread started (pid=1689, tid=2369)
Sep  3 17:29:58 sat vdr: [2370] buffer usage: 70% (tid=2369)
Sep  3 17:29:58 sat vdr: [2370] buffer usage: 80% (tid=2369)
Sep  3 17:29:58 sat vdr: [2370] buffer usage: 90% (tid=2369)
Sep  3 17:29:59 sat vdr: [2368] ERROR: streamdev-server: couldn't send data: Die Wartezeit für die Verbindung ist abgelaufen
 

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #170 on: September 03, 2012, 18:00:38 »
Hi,

die mpeg2 Lizenz hat noch keine Auswirkung, da es noch kein VDR-Frontend gibt, das den Hardware Decoder nutzen kann.
Das System bleibt vermutlich aus Speichermangel stehen. Das ist jedoch auf nen Fehler zurück zu führen, den ich noch nicht gefunden habe. Eigentlich sollte nach abgeschlossenem Bootvorgang noch reichlich Speicher frei sein.
Wenn Du den RPI als streamning client einsetzt kann es durchaus sein, dass der beim zweiten Reboot nicht mehr hängen bleibt. Es könnte dann auch helfen das nfs-client Addon von der SD Karte (unter /etc/addons) zu löschen, da ich das als Ursache des
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Rudi

  • Newbie
  • *
  • Posts: 24
    • View Profile
Raspberry Pi
« Reply #171 on: September 04, 2012, 09:21:33 »
mld-server läuft schön rund. Nur das Bearbeiten der channels.conf über web-if will aus irgendeinem Grund nicht. Die vorgefertigten channels.conf kann man aber auswählen.

Lastprobleme habe ich auf der Server-Ausführung logischerweise auch nicht. Andere Images habe ich nicht ausprobiert.

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #172 on: September 04, 2012, 12:05:10 »
Hi Rudi,

hast Du an dem RPI DVB-Empfänger angeschlossen? Wenn ja, wie hoch ist die Prozessorlast, und falls ersichtlich die der Treiber?
Das Bearbeiten der channels.conf schaue ich mir noch mal an.

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #173 on: September 04, 2012, 12:08:31 »
Ich hab gestern Abend mal den Omxplayer verwendet um nen HDTV Sender (über Streamdev) auszugeben. Das funktionierte problemlos. Ich hatte nur versäumt zu schauen wie hoch damit die Systemlast ist. Das muss ich noch mal nachholen. SDTV geht noch nicht, weil ich mir noch keine mpeg2 Lizenz für den geliehenen RPI besorgt habe. Das werde ich aber die nächsten Tage nachholen.

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline MarMic

  • Administrator
  • Expert Member
  • ********
  • Posts: 4811
    • View Profile
Raspberry Pi
« Reply #174 on: September 04, 2012, 12:43:28 »
haste selbst immer noch keinen pi?
SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - DVBSky S952 - Astra 19,2 - MLD 5.4

WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLD 5.4


Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #175 on: September 04, 2012, 13:45:48 »
Ne, der soll aber ende des Monats kommen,...

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline skippy

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2157
    • View Profile
Raspberry Pi
« Reply #176 on: September 05, 2012, 08:11:03 »
Weiß nicht, ob euch diese Info von hier hilft.

Quote
Oh and RPI Support just got pushed in too  :)

Viele Grüße skippy
meine MLDs (show / hide)

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #177 on: September 05, 2012, 10:40:13 »
Interessant, aber für den RPI wird nen angepasster Branch benötigt. Trotzdem ist das nett zu wissen, denn dann wird das wohl bald mit in die Ubuntu Pakete mit einfließen :)

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18288
    • View Profile
    • ClausMuus.de
Raspberry Pi
« Reply #178 on: September 05, 2012, 10:49:51 »
Ich hab gestern auf den Kernel 3.2.27 umgestellt. Und diesmal habe ich sogar schon getestet ob die neuen Images funktionieren. Das client Image läuft bei mir jedenfalls schon mal recht gut. Ich hab nur noch nen paar böse Kernel Meldungen, und beim xorg Start gibt's diverse "out of memmory" Meldungen, die aber scheinbar erst einmal keine wirklich störenden Nebenwirkungen haben.
Es gilt weiterhin, das es kein VDR Ausgabe Tool gibt, das die Hardwarebeschleunigung nutzt, weshalb die TV Ausgabe ruckelt. Dies ist auch weiterhin so, bis ich was anderes berichte.

Testweise hatte ich gestern Abend noch mal mit dem Omxplayer nen HDTV Stream ausgegeben. Die Systemlast des Players beträgt 40%, was mir recht hoch vorkommt. Wenn das wirklich nicht besser geht, sind ja leider nicht mehr all zu viele Resourcen frei für andere Aufgaben...
Als nächstes werde ich mal schauen was passiert wenn man gleichzeitig nen xterm startet, und ob es die Wiedergabe stört wenn das xterm Fenster im Vordergrund liegt.

Claus
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline MarMic

  • Administrator
  • Expert Member
  • ********
  • Posts: 4811
    • View Profile
Raspberry Pi
« Reply #179 on: September 05, 2012, 10:55:44 »
@claus,

ich verfolge das pi überall sonst

habe mitbekommen das auch rpi in xbmc gemerged wurde (was auch immer ich mir darunetr vorstellen muss) -> jedenfalls soll nun mit codec lizenz sd und hdtv absolut flüssig abspielen (da haste dein frontend :-P)

zudem habe ich noch was gelesen mit ner bootoption die das pi stabieler machen soll ...

von hepi im protal gepostet: http://forum.stmlabs.com/showthread.php?tid=2508

und dann noch

http://www.raspbmc.com/2012/09/raspbmc-get...install-codecs/

greetz MarMic

edit: stab : http://www.raspberrypi.org/phpBB3/viewtopi...hp?f=24&t=14394
« Last Edit: September 05, 2012, 10:57:18 by MarMic »
SZVDR HD: Intel e5300@1,2ghz - Gigabyte GA-EP41-UD3L - 2GB ddr2 800 - Gainward G210 512mb - Silverstone LC16MR - DVBSky S952 - Astra 19,2 - MLD 5.4

WZVDR HD: Intel g1610@1,6ghz - Intel DH61BE - Scythe Big Shuriken 2 - 4GB ddr3 1333 - Asus GT610 1024mb - Chieftec Hi-Fi HM-02 - Tevii s480 - Astra 19,2 - MLD 5.4


1 ... 10 11 [12] 13 14 ... 27 >>> Archiv / MLD 3.x / Raspberry PI / Raspberry Pi
 



Users Online Users Online

0 Members and 2 Guests are viewing this topic.