Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - TimUx

16
Raspberry PI / [MLD 5.4] Bobloght Plugin läuft nicht
« on: November 03, 2017, 22:55:45 »
Hallo zusammen,
das es mit dem aktuell hyperion Plugin anscheinend Probleme mit dem "internen" Grabber bei 1080p wiedergabe gibt, wollte ich mal wieder boblight testen.

Leider funktioniert das VDR nicht mehr, sobald mal das vdr-boblight-plugin installiert.
Folgende Fehler werden im der /var/log/messages angezeigt.

Code: [Select]
Nov  3 22:11:15 (none) user.err vdr: [24326] ERROR: libboblight.so.0: cannot open shared object file: No such file or directory
Nov  3 22:11:16 (none) user.err vdr: [24445] ERROR: libboblight.so.0: cannot open shared object file: No such file or directory
Nov  3 22:11:16 (none) user.err vdr: [24445] ERROR (ci.c,2990): (null): Bad address

Gruß Timo

17
Hallo zusammen,
ich wollte heute wieder mal ein upgrade durchführe, es kann aber ein Paket nicht gefunden werden.

Code: [Select]
rpi3> apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  alsa:armhf-rpi2 eventlircd:armhf-rpi2 hid:armhf-rpi2 i2c:armhf-rpi2 network:armhf-rpi2 network-wireless-rpi3:armhf-rpi2 nfs-server:armhf-rpi2
  rc-core:armhf-rpi2 rpi-rtc:armhf-rpi2 sensors:armhf-rpi2
The following packages will be upgraded:
  btrfs:armhf-rpi2
1 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
Need to get 681 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 http://www.minidvblinux.de/download/5.4/files testing/main armhf-rpi2 btrfs armhf-rpi2 4.7.3-114.2+4.4..199.19
  404  Not Found
E: Failed to fetch http://www.minidvblinux.de/download/5.4/files/testing/armhf-rpi2/btrfs_4.7.3-114.2+4.4..199.19_armhf-rpi2.deb  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
rpi3>

Gruß Timo

18
Entwicklung [ Development ] / Docker Pakete
« on: October 21, 2017, 19:54:15 »
Hallo zusammen,
wir hatten mal darüber gesprochen, bei welchen Paketen es Sinn machen würde, diese als Docker über das docker-pt zu installieren.

Vielleicht können wir hier ein paar Ideen sammeln.

Mein erster Vorschlag wäre z.B. "emby" (Plex Alternative).
https://hub.docker.com/r/emby/embyserver/


Gruß Timo

19
WeTek Play / [5.4] USB Devices werden nicht erkannt
« on: August 17, 2017, 19:46:56 »
Hallo zusammen,
ich habe den einen oder andere Card Reader, welche ich versucht habe auf der WeTek mit MLD 5.4 ans rennen zu bekommen.

Anscheinend werde diese laut DMESG erkannt, es werden aber keine USB Devices unter /dev erstellt.

Code: [Select]
[  805.128092@1] usb 2-1: new full-speed USB device number 2 using dwc_otg
[  805.348981@0] usb 2-1: New USB device found, idVendor=0403, idProduct=6001
[  805.348997@0] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  805.349003@0] usb 2-1: Product: Smartreader2 plus
[  805.349009@0] usb 2-1: Manufacturer: Argolis BV
[  805.349015@0] usb 2-1: SerialNumber: smargo01

MLD-SERVER> lsusb
Bus 001 Device 002: ID 05e3:0608
Bus 002 Device 002: ID 0403:6001
Bus 001 Device 001: ID 1d6b:0002
Bus 002 Device 001: ID 1d6b:0002
Bus 001 Device 003: ID 2252:0106

MLD-SERVER> ls -la /dev/ttyU*
ls: /dev/ttyU*: No such file or directory

Mit einem RPI oder x64 Server sieht das ganz dann in etwas so aus:

Code: [Select]
[    2.843746] usb 1-8: new full-speed USB device number 2 using xhci_hcd
[    3.018060] usb 1-8: New USB device found, idVendor=0403, idProduct=6001
[    3.018062] usb 1-8: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.018063] usb 1-8: Product: FT232R USB UART
[    3.018064] usb 1-8: Manufacturer: FTDI
[    3.018065] usb 1-8: SerialNumber: AL00CTNJ
[    3.020780] usb 1-8: Detected FT232RL
[    3.021122] usb 1-8: FTDI USB Serial Device converter now attached to ttyUSB0

server> lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 003: ID 0f30:0001 Jess Technology Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

server> ls -la /dev/ttyU*
crw-rw----    1 root     dialout   188,   0 Aug 17 19:23 /dev/ttyUSB0

Hat jemand eine Idee, welches Problem die Wetek hier haben könnte?

Danke & Gruß
Timo

20
x86 Systeme (PC) / [5.4] schlechte Empfangseigenschaften
« on: August 17, 2017, 19:37:33 »
Hallo zusammen,
ich habe mich die Tage immer wieder gewundert, dass ich mal Klötzchen und Aussetzer habe mit meinem MLD 5.4 Server habe.

Ich habe hier minisatip installiert und greife mit mehrere SATIP Clients darauf zu, unter anderem der Server selbst.
Als ich mal in das SATIP WebIf rein geschaut habe, ist mir aufgefallen, dass die Empfangsdaten nicht gerade berauschent sind.

STR: 75 - 80%
SNR: 28 - 33%

Ich habe mittlerweile so ziemlich alle DVB Pakete getestet, keine Besserung.
Ein Hardware Problem habe ich bereits ausgeschlossen.

Ich habe dann zum Test mal einen MLD 5.1 stable Live Stick mit dvb und minisatip installiert.

Siehe da:

STR: 89 - 92%
SNR: 90 - 95%

Somit scheint dies ein Software / Treiber Problem zu sein.

Zum Einsatz kommen hier meine zwei DD Cine 6.5 Karten.

Kann jemand ein ähnliches Verhalten beobachten oder hat eine Idee, was dies sein könnte?

Gruß Timo

21
x86 Systeme (PC) / Can't open shared library 'mysqlepglv.so
« on: August 14, 2017, 16:27:02 »
Hi,
ich habe gerade mal versucht ein frisches MLD 5.4 testing mit mariadb und epg-daemon zu installieren.

Leider scheidert dies:


Code: [Select]
--------------
CREATE FUNCTION epglv RETURNS INT SONAME 'mysqlepglv.so'
--------------

ERROR 1126 (HY000) at line 1: Can't open shared library 'mysqlepglv.so' (errno: 11, cannot open shared object file: No such file or directory)
--------------
CREATE FUNCTION epglvr RETURNS INT SONAME 'mysqlepglv.so'
--------------

ERROR 1126 (HY000) at line 1: Can't open shared library 'mysqlepglv.so' (errno: 11, cannot open shared object file: No such file or directory)

Da scheint eine library zu fehlen?

Gruß Timo

22
x86 Systeme (PC) / [5.4] nsora und tools beißen sich!?!
« on: August 02, 2017, 18:53:09 »
Code: [Select]

server> apt-get install nsora
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  nsora
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/63,0 kB of archives.
After this operation, 184 kB of additional disk space will be used.
(Reading database ... 35974 files and directories currently installed.)
Preparing to unpack .../archives/nsora_0-9_amd64.deb ...
Unpacking nsora (0-9) ...
dpkg: error processing archive /var/cache/apt/archives/nsora_0-9_amd64.deb (--unpack):
 trying to overwrite '/bin/netstat', which is also in package tools 0-20.1
Errors were encountered while processing:
 /var/cache/apt/archives/nsora_0-9_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



Gruß Timo

23
Allgemein [ General ] / [5.4] mariadb kein mysqldump
« on: August 01, 2017, 22:21:10 »
Hallo zusammen,
ich vermisse beim mariabb-server paket das tool mysqldump.

Beim alten mysql-server Paket war dies dabei.

Ich nutze es zumsammen mit cron um meine DBs zu sichern.

Gruß Timo

24
Hallo zusammen,
bei einigen NAS Distries gibt es eine Autoshutdown Funktion, die ähnlich wie beim NSORA auf Clients achtet nur nur herunter fährt, wenn keine Services mehr genutzt werden.

Zusätzlich kann man eine Kernzeit angeben ( z.B. 08:00 - 22:00 ), in welcher der Server immer online sein soll.
Außerdem wird der Server dann auch immer zur Startuhrzeit gebootet, sollte er noch offline Sein.

Solch eine Funktion fände ich persönlich für eine MLD Server, welche MLD VDR Clients aber auch Dienste wie Owncloud usw bietet, nicht schlecht.

Eventuell könnte man das NSORA entsprechend erweitern?

Gruß Timo


25
Wünsche [ Feature requests ] / Syncthing
« on: July 29, 2017, 22:44:18 »
Hallo zusammen,
ich habe mal ein wenig mit Syncthing herumg gespielt und finde es eigentlich ganz nett.

https://syncthing.net/

Wäre eine Nette und einfache Alternative zu Owncloud um all seine Daten zwischen unterschiedlichen geräten Synchron zu halten.

Hier gibt es sogar fertige deb Pakete.

Vielleicht findet ja jemand mal kurz zeit in MLD 5.4 ein Paket zu bauen, ich würde es auch testen.  ;)

Gruß Timo

26
Raspberry PI / [5.3] + [5.4] RPI CEC Funktioniert nicht
« on: July 28, 2017, 22:44:54 »
Hallo zusammen,
bei mir funktioniert auf meinem RPI3 mit 5.4 Testing weder der libcec-daemon noch das vdr-pluhin-cecremote.

Der CEC Adapter wird irgendwie nicht erkannt.

Code: [Select]
Jul 28 22:31:29 (none) user.debug vdr: [cecremote] Load keymap
Jul 28 22:31:34 (none) user.err vdr: [cecremote] Can not open /proc/driver/rtc: No such file or directory
Jul 28 22:31:35 (none) user.err vdr: [cecremote] No adapter found
Jul 28 22:31:35 (none) user.err vdr: [cecremote] PowerOnDevice ignored
Jul 28 22:31:35 (none) user.err vdr: [cecremote] SetActiveSource ignored


rpi3> libcec-daemon
INFO - Opened /dev/uinput
INFO - Created uinput device
No adapters found


rpi3> cec-client
No device type given. Using 'recording device'
CEC Parser created - libCEC version 4.0.1
no serial port given. trying autodetect: FAILED

Ideen?

Gruß Timo

27
WeTek Play / [5.4] VDR Server Test / Erfahrung
« on: July 17, 2017, 19:41:19 »
Hallo zusammen,
ich hatte wieder mal etwas lust zu spielen und zu testen und wollte auf meiner Wetek-Play mal einen 5.4er VDR Server mit netinstall aufsetzten.

Das System bootet zwar von der SD, leider startet aber das Installations-Menü nicht und die Console ist auch nicht benutzbar.
Ich habe dann 5.3 Testing installiert und ein upgrade auf 5.4 durchgeführt, das hat FUnktioniert und der VDR läuft.

Kann sich jemand mal anschauen, warum im 5.4 Testing Wetek-Play Image das maria-db Paket nicht bauen lässt?
Ich würde gerne mal den epg-daemon installieren und testen.

Danke & Gruß
Timo

28
x86 Systeme (PC) / [5.3] Nicht alle Tuner werden erkannt.
« on: May 31, 2017, 16:34:54 »
Hallo zusammen,
nachdem ich ein Dist-Upgrade von 5.1 Stabel auf 5.3 Stable durchgeführt habe, werden nicht mehr alle 6 Tuner erkannt.

Ich setze aktuell folge DVB-S Karten ein.

- 2x L4M-Twin S2 ver 6.5
- 1x L4M-Twin S2 ver 5.4

Die 6.5er Karten scheinen sauber zu laufen, die 5.4 wird anscheinend aber nicht mehr erkannt.

Ich habe sowohl das "dvb" als auch das "dvb-mb" Paket getestet.
Unter 5.1 mit dem "dvb-mbe" läuft alles ohne Probleme.

Was fehlt im "dvb-mb" Paket, was vorher im "dvb-mbe" enhalten war?

Ach ja beim "dvb-mb" Paket ist auch die Signalstärke im Vergleich zum "dvb" oder "dvb.mbe" echt Mies.

Gruß Timo

29
Hallo zusammen,
hat denn überhaupt mal jemand in 5.3 Testing das nginx und php in Verbindung mit owncloud getestet, bevor 5.3 zu stable gemacht wurde?

Anscheinend wurde auf php7 umgestellt, was ich persönlich aktuell noch nicht gut finde.

Dabei wurden aber z.B. in Start-Skript vergessen, den Deamon auf php7 umzustellen.

Code: [Select]
server> ls -la /etc/init.d/php-fpm
-rwxr-xr-x    1 root     root           581 May 10 11:04 /etc/init.d/php-fpm
server> cat /etc/init.d/php-fpm
#!/bin/sh

. /etc/init.d/rc.functions

NAME=${0##*/}
DAEMON=/usr/sbin/php5-fpm
ARGS="--daemonize --fpm-config /etc/php5/fpm/php-fpm.conf -R"
PID_FILE=/var/run/$NAME.pid

Wenn man owncloud neu installier, bekommt man direkt PHP Module angezeigt, welche noch fehlen.

Code: [Select]
Setting up owncloud (9.1.3-17) ...
Failed loading /usr/lib/php/20151012/opcache.so:  /usr/lib/php/20151012/opcache.so: cannot open shared object file: No such file or directory
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/xml.so' - /usr/lib/php/20151012/xml.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/apc.so' - /usr/lib/php/20151012/apc.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/dom.so' - /usr/lib/php/20151012/dom.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/simplexml.so' - /usr/lib/php/20151012/simplexml.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/wddx.so' - /usr/lib/php/20151012/wddx.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/xmlreader.so' - /usr/lib/php/20151012/xmlreader.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/xmlwriter.so' - /usr/lib/php/20151012/xmlwriter.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php/20151012/xsl.so' - /usr/lib/php/20151012/xsl.so: cannot open shared object file: No such file or directory in Unknown on line 0
ownCloud is not installed - only a limited number of commands are available
PHP module zip not installed.
Please ask your server administrator to install the module.

PHP module dom not installed.
Please ask your server administrator to install the module.

PHP module XMLWriter not installed.
Please ask your server administrator to install the module.

PHP module XMLReader not installed.
Please ask your server administrator to install the module.

PHP module libxml not installed.
Please ask your server administrator to install the module.

PHP module mb multibyte not installed.
Please ask your server administrator to install the module.

PHP module SimpleXML not installed.
Please ask your server administrator to install the module.

An unhandled exception has been thrown:
Exception: Environment not properly prepared. in /var/www/owncloud/lib/private/Console/Application.php:120

Die nginx Site für owncloud wurde ebenfalls noch nicht auf php7 umgestellt.

Code: [Select]
server> cd /etc/nginx/sites-available/
server> ls -la
drwxr-xr-x    1 root     root            16 May 28 21:01 .
drwxr-xr-x    1 root     root            56 May 28 20:59 ..
-rw-r--r--    1 root     root          3115 May 28 21:01 owncloud
server> cat owncloud
upstream php-handler {
        #server 127.0.0.1:9000;
        server unix:/var/run/php5-fpm.sock;
}


In dem zusammenhang, mit all den anderen Probleme, welche ich aktuell noch mit 5.3 Stable habe, werde ich erst einmal mit dem Snap auf 5.1 zurück gehen.

Gruß Timo

30
Code: [Select]
wget: server returned error: HTTP/1.1 404 Not Found
Download and install skindesigner-white
tar: can't open 'skindesigner-white-.tar.bz2': No such file or directory
cp: can't stat 'skindesigner-white/*': No such file or directory
failed

Wollte gerade mal die Logos wechseln, dabei kam ob die Fehlermeldung.

Hat sich die Url zu den Channellogos geändert?

Gruß Timo