1 2 [3] MLD-5.x / General / RPi4: docker installieren
 

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18595
    • View Profile
    • ClausMuus.de
RPi4: docker installieren
« Reply #30 on: July 31, 2020, 23:15:19 »
iptables wird automatisch mit installiert. Nur ist das Paket für die MLD-5.5 nicht lauffähig. Ich habe es jetzt überarbeitet.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Online herrdeh

  • Adv. Member
  • ***
  • Posts: 130
    • View Profile
RPi4: docker installieren
« Reply #31 on: August 02, 2020, 19:14:39 »
Habe upgedatet: apt update & upgrade

Dann:
Code: [Select]
MLD> docker version
Client: Docker Engine - Community
 Version:           19.03.7
 API version:       1.40
 Go version:        go1.12.17
 Git commit:        7141c19
 Built:             Wed Mar  4 01:56:07 2020
 OS/Arch:           linux/arm
 Experimental:      false
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

Code: [Select]
MLD> dockerd
INFO[2020-08-02T19:10:37.185827788+02:00] Starting up                                 
INFO[2020-08-02T19:10:37.202966506+02:00] libcontainerd: started new containerd process  pid=3136
INFO[2020-08-02T19:10:37.203754803+02:00] parsed scheme: "unix"                         module=grpc
INFO[2020-08-02T19:10:37.203916637+02:00] scheme "unix" not registered, fallback to default scheme  module=grpc
INFO[2020-08-02T19:10:37.204488582+02:00] ccResolverWrapper: sending update to cc: {[{unix:///var/run/docker/containerd/containerd.sock 0  <nil>}] <nil>}  module=grpc
INFO[2020-08-02T19:10:37.204702508+02:00] ClientConn switching balancer to "pick_first"  module=grpc
INFO[2020-08-02T19:10:37.408751353+02:00] starting containerd                           revision=7ad184331fa3e55e52b890ea95e65ba581ae3429 version=1.2.13
INFO[2020-08-02T19:10:37.411720188+02:00] loading plugin "io.containerd.content.v1.content"...  type=io.containerd.content.v1
INFO[2020-08-02T19:10:37.412122596+02:00] loading plugin "io.containerd.snapshotter.v1.btrfs"...  type=io.containerd.snapshotter.v1
INFO[2020-08-02T19:10:37.413366227+02:00] loading plugin "io.containerd.snapshotter.v1.aufs"...  type=io.containerd.snapshotter.v1
WARN[2020-08-02T19:10:37.458521748+02:00] failed to load plugin io.containerd.snapshotter.v1.aufs  error="modprobe aufs failed: "modprobe: module aufs not found in modules.dep\n": exit status 1"
INFO[2020-08-02T19:10:37.459409212+02:00] loading plugin "io.containerd.snapshotter.v1.native"...  type=io.containerd.snapshotter.v1
INFO[2020-08-02T19:10:37.460321916+02:00] loading plugin "io.containerd.snapshotter.v1.overlayfs"...  type=io.containerd.snapshotter.v1
INFO[2020-08-02T19:10:37.461833325+02:00] loading plugin "io.containerd.snapshotter.v1.zfs"...  type=io.containerd.snapshotter.v1
INFO[2020-08-02T19:10:37.464036475+02:00] skip loading plugin "io.containerd.snapshotter.v1.zfs"...  type=io.containerd.snapshotter.v1
INFO[2020-08-02T19:10:37.464293123+02:00] loading plugin "io.containerd.metadata.v1.bolt"...  type=io.containerd.metadata.v1
WARN[2020-08-02T19:10:37.464658531+02:00] could not use snapshotter aufs in metadata plugin  error="modprobe aufs failed: "modprobe: module aufs not found in modules.dep\n": exit status 1"
WARN[2020-08-02T19:10:37.464988142+02:00] could not use snapshotter zfs in metadata plugin  error="path /var/lib/docker/containerd/daemon/io.containerd.snapshotter.v1.zfs must be a zfs filesystem to be used with the zfs snapshotter: skip plugin"
INFO[2020-08-02T19:10:37.466054828+02:00] loading plugin "io.containerd.differ.v1.walking"...  type=io.containerd.differ.v1
INFO[2020-08-02T19:10:37.466306569+02:00] loading plugin "io.containerd.gc.v1.scheduler"...  type=io.containerd.gc.v1
INFO[2020-08-02T19:10:37.467145144+02:00] loading plugin "io.containerd.service.v1.containers-service"...  type=io.containerd.service.v1
INFO[2020-08-02T19:10:37.467403144+02:00] loading plugin "io.containerd.service.v1.content-service"...  type=io.containerd.service.v1
INFO[2020-08-02T19:10:37.467643885+02:00] loading plugin "io.containerd.service.v1.diff-service"...  type=io.containerd.service.v1
INFO[2020-08-02T19:10:37.467979812+02:00] loading plugin "io.containerd.service.v1.images-service"...  type=io.containerd.service.v1
INFO[2020-08-02T19:10:37.468301071+02:00] loading plugin "io.containerd.service.v1.leases-service"...  type=io.containerd.service.v1
INFO[2020-08-02T19:10:37.468609627+02:00] loading plugin "io.containerd.service.v1.namespaces-service"...  type=io.containerd.service.v1
INFO[2020-08-02T19:10:37.468963349+02:00] loading plugin "io.containerd.service.v1.snapshots-service"...  type=io.containerd.service.v1
INFO[2020-08-02T19:10:37.469414554+02:00] loading plugin "io.containerd.runtime.v1.linux"...  type=io.containerd.runtime.v1
INFO[2020-08-02T19:10:37.470239702+02:00] loading plugin "io.containerd.runtime.v2.task"...  type=io.containerd.runtime.v2
INFO[2020-08-02T19:10:37.470799925+02:00] loading plugin "io.containerd.monitor.v1.cgroups"...  type=io.containerd.monitor.v1
INFO[2020-08-02T19:10:37.474732447+02:00] loading plugin "io.containerd.service.v1.tasks-service"...  type=io.containerd.service.v1
INFO[2020-08-02T19:10:37.475112447+02:00] loading plugin "io.containerd.internal.v1.restart"...  type=io.containerd.internal.v1
INFO[2020-08-02T19:10:37.475455374+02:00] loading plugin "io.containerd.grpc.v1.containers"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.475607133+02:00] loading plugin "io.containerd.grpc.v1.content"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.475754096+02:00] loading plugin "io.containerd.grpc.v1.diff"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.475888059+02:00] loading plugin "io.containerd.grpc.v1.events"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.476018504+02:00] loading plugin "io.containerd.grpc.v1.healthcheck"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.476144226+02:00] loading plugin "io.containerd.grpc.v1.images"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.476264430+02:00] loading plugin "io.containerd.grpc.v1.leases"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.476391412+02:00] loading plugin "io.containerd.grpc.v1.namespaces"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.476516801+02:00] loading plugin "io.containerd.internal.v1.opt"...  type=io.containerd.internal.v1
INFO[2020-08-02T19:10:37.477378912+02:00] loading plugin "io.containerd.grpc.v1.snapshots"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.477567301+02:00] loading plugin "io.containerd.grpc.v1.tasks"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.477697302+02:00] loading plugin "io.containerd.grpc.v1.version"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.477879894+02:00] loading plugin "io.containerd.grpc.v1.introspection"...  type=io.containerd.grpc.v1
INFO[2020-08-02T19:10:37.479408173+02:00] serving...                                    address="/var/run/docker/containerd/containerd-debug.sock"
INFO[2020-08-02T19:10:37.479881285+02:00] serving...                                    address="/var/run/docker/containerd/containerd.sock"
INFO[2020-08-02T19:10:37.480040081+02:00] containerd successfully booted in 0.074985s 
INFO[2020-08-02T19:10:37.528299012+02:00] parsed scheme: "unix"                         module=grpc
INFO[2020-08-02T19:10:37.528923476+02:00] scheme "unix" not registered, fallback to default scheme  module=grpc
INFO[2020-08-02T19:10:37.529373532+02:00] ccResolverWrapper: sending update to cc: {[{unix:///var/run/docker/containerd/containerd.sock 0  <nil>}] <nil>}  module=grpc
INFO[2020-08-02T19:10:37.529780495+02:00] ClientConn switching balancer to "pick_first"  module=grpc
INFO[2020-08-02T19:10:37.534671036+02:00] parsed scheme: "unix"                         module=grpc
INFO[2020-08-02T19:10:37.535351000+02:00] scheme "unix" not registered, fallback to default scheme  module=grpc
INFO[2020-08-02T19:10:37.535962926+02:00] ccResolverWrapper: sending update to cc: {[{unix:///var/run/docker/containerd/containerd.sock 0  <nil>}] <nil>}  module=grpc
INFO[2020-08-02T19:10:37.536212371+02:00] ClientConn switching balancer to "pick_first"  module=grpc
WARN[2020-08-02T19:10:37.662577926+02:00] Your kernel does not support cgroup memory limit
WARN[2020-08-02T19:10:37.662796870+02:00] Your kernel does not support cgroup cfs period
WARN[2020-08-02T19:10:37.662950074+02:00] Your kernel does not support cgroup cfs quotas
WARN[2020-08-02T19:10:37.663158204+02:00] Your kernel does not support cgroup rt period
WARN[2020-08-02T19:10:37.663431204+02:00] Your kernel does not support cgroup rt runtime
WARN[2020-08-02T19:10:37.663610112+02:00] Your kernel does not support cgroup blkio weight
WARN[2020-08-02T19:10:37.663832390+02:00] Your kernel does not support cgroup blkio weight_device
INFO[2020-08-02T19:10:37.665096798+02:00] Loading containers: start.                   
WARN[2020-08-02T19:10:37.781801604+02:00] Running iptables --wait -t nat -L -n failed with message: `iptables: Operation not supported.`, error: exit status 1
INFO[2020-08-02T19:10:38.873966403+02:00] stopping event stream following graceful shutdown  error="<nil>" module=libcontainerd namespace=moby
INFO[2020-08-02T19:10:38.875786608+02:00] stopping event stream following graceful shutdown  error="context canceled" module=libcontainerd namespace=plugins.moby
INFO[2020-08-02T19:10:38.876266590+02:00] stopping healthcheck following graceful shutdown  module=libcontainerd
failed to start daemon: Error initializing network controller: error obtaining controller instance: failed to create NAT chain DOCKER: iptables failed: iptables -t nat -N DOCKER: iptables: Operation not supported.
 (exit status 1)

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18595
    • View Profile
    • ClausMuus.de
RPi4: docker installieren
« Reply #32 on: August 02, 2020, 23:00:56 »
Hm, jetzt muss wohl mal einer von uns selber testen um das Problem mit dem iptables zu finden.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

1 2 [3] MLD-5.x / General / RPi4: docker installieren
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.