[1] MLD-6.x / General / Kein Ton von CMI8738-basierter PCI-Soundkarte
 

Offline villeneuve

  • Adv. Member
  • ***
  • Posts: 109
    • View Profile
Kein Ton von CMI8738-basierter PCI-Soundkarte
« on: May 03, 2024, 13:27:32 »
Hi,
nach frischer Installation von 6.4 habe ich keinen Ton von meiner Terratec Aureon 5.1 Fun TTP8 Ver 1.0, einer CMI8738-basierten PCI-Soundkarte, die normalerweise unter Linux funktioniert.
Im MLD-Setup werden nur HDMI-Ausgänge angeboten, die Soundkarte taucht gar nicht auf.
cat /proc/asound/cards und aplay -l listen auch nur die HDMI-Ausgänge der Nvidia GT220 auf.
Wo liegt der Hund begraben?
Haupt-VDR: Gigabyte GA-F2A88XM-HD3 - AMD A8-7600 - 4 Gb RAM - Ausgabe via MSI N220GT-MD1GZ mit softhddevice & vdpau - 19.2E & 28.2E Empfang via Linux4Media L4M-Twin S2 ver 6.5 - Terratec Aureon 5.1 Fun TTP8 - Crucial m4 CT064M4SSD2 - Seagate Exos 7E8 - Medion X10 RF Remote Control 20016398

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 20199
    • View Profile
    • ClausMuus.de
Kein Ton von CMI8738-basierter PCI-Soundkarte
« Reply #1 on: May 03, 2024, 18:45:57 »
Vermutlich fehlt der Treiber für die Soundkarte. Falls Du weißt, welcher dafür benötigt wird, könnten wir mal schauen ob der im Kernel aktiviert werden kann.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline villeneuve

  • Adv. Member
  • ***
  • Posts: 109
    • View Profile
Kein Ton von CMI8738-basierter PCI-Soundkarte
« Reply #2 on: May 03, 2024, 19:15:06 »
Hm, welchen Sinn macht es im Kernel enthaltene Treiber, wie es in diesem Fall ist, zu deaktiveren? Oder heißt deaktivieren gleichzeitig auch löschen, so daß man einen schlankeren Kernel erhält? In älteren MLD-Versionen lief die Soundkarte übrigens immer nach kleinem manuellem Eingriff. Es handelt sich beim CMI8738 auch um einen Wald und Wiesen Soundchip, der weit verbreitet ist (ok, wieviele davon noch in HTPCs stecken ist eine andere Frage).
Ich hoffe die relevanten Infos gefunden zu haben:
Treiber wird wohl dieser sein:
https://linux-hardware.org/?id=pci:13f6-0111-153b-1144
https://cateee.net/lkddb/web-lkddb/SND_CMIPCI.html

Notizen zu dem Treiber:
https://www.kernel.org/doc/html/latest/sound/cards/cmipci.html
Haupt-VDR: Gigabyte GA-F2A88XM-HD3 - AMD A8-7600 - 4 Gb RAM - Ausgabe via MSI N220GT-MD1GZ mit softhddevice & vdpau - 19.2E & 28.2E Empfang via Linux4Media L4M-Twin S2 ver 6.5 - Terratec Aureon 5.1 Fun TTP8 - Crucial m4 CT064M4SSD2 - Seagate Exos 7E8 - Medion X10 RF Remote Control 20016398

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 20199
    • View Profile
    • ClausMuus.de
Kein Ton von CMI8738-basierter PCI-Soundkarte
« Reply #3 on: May 04, 2024, 01:36:39 »
Wir verwenden weitestgehend die Yocto Voreinstellungen, bei denen nicht alle Sound Treiber aktiv sind.
Ich habe für's erste den von Dir benötigten Sound Treiber aktiviert.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline villeneuve

  • Adv. Member
  • ***
  • Posts: 109
    • View Profile
Kein Ton von CMI8738-basierter PCI-Soundkarte
« Reply #4 on: May 13, 2024, 18:08:00 »
Danke für's schnelle Aufnehmen des Treibers!
Gerade bin ich endlch wieder zum Testen gekommen. Die Soundkarte wird nach MLD-Update und Reboot erkannt und es stehen auch die beiden Analogausgänge sowie der SPDIF-Ausgang zur Auswahl im MLD-Webinterface. Ton bekomme ich aber leider nicht heraus. Auf MLD 5.4 mußte ich noch den Nvidia HDMI-Sound deaktivieren mittels einer /etc/modprobe.d/blacklist.conf und im Alsamixer Ausgänge einschalten um Ton zu bekommen, aber /proc/asound/modules und den Alsamixer gibt es auf MLD 6.4 nicht. Wie ist das Ein-/Auschalten von Ausgängen und festlegen von Lautstärken bei MLD 6.4 vorgesehen? Oder was kann ich alternativ versuchen?

*EDIT* Habe noch versucht mittels alsa-update-asound-conf.sh und alsa-init.sh mit abschließendem alsactl store etwas zu erreichen und dabei ist /var/lib/alsa/asound.state neu erstellt worden, aber VDR blieb weiterhin stumm.
« Last Edit: May 13, 2024, 18:38:56 by villeneuve »
Haupt-VDR: Gigabyte GA-F2A88XM-HD3 - AMD A8-7600 - 4 Gb RAM - Ausgabe via MSI N220GT-MD1GZ mit softhddevice & vdpau - 19.2E & 28.2E Empfang via Linux4Media L4M-Twin S2 ver 6.5 - Terratec Aureon 5.1 Fun TTP8 - Crucial m4 CT064M4SSD2 - Seagate Exos 7E8 - Medion X10 RF Remote Control 20016398

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 20199
    • View Profile
    • ClausMuus.de
Kein Ton von CMI8738-basierter PCI-Soundkarte
« Reply #5 on: May 14, 2024, 08:48:03 »
Es gibt ein alsamixer oder alsautils Paket, oder so was ähnliches. Damit kannst Du den Alsamixer installieren.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

[1] MLD-6.x / General / Kein Ton von CMI8738-basierter PCI-Soundkarte
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.