[1] MLD-6.x / General / Test MLD-6.4 mit ThinkCentre M720q by strike
 

Offline strike

  • Member
  • **
  • Posts: 64
    • View Profile
Test MLD-6.4 mit ThinkCentre M720q by strike
« on: March 31, 2024, 11:19:20 »
Hallo,

Hier mein Test mit MLD 6.4 auf einem ThinkCentre M720q.

Pro:
1., Installation war super easy. Als Stream-Client hat sofort alles funktioniert.
2., Neue Oberfläche Top
3., Der RP2040-One war super einfach einzubinden. Tasten anlernen TOP. Wie ich das auf dem M720Q mit dem Einschalten mache, muss ich noch schauen, wo ich diesen am Mainboard anlöten muss.
4., Skin FlatPlus sieht super aus, gab es glaube ich aber schon bei MLD 5.5

Contra:
1., Wenn ich F1, also Aufnahmen drücke, schmiert der VDR ab. Skin ist Skin-FlatPlus. Mit Standard-Skin kein Absturz.
Code: [Select]
Mär 31 10:56:33 MLD6-WZ kernel: traps: vdr[7125] trap divide error ip:7fdd3857c07e sp:7ffd9e709730 error:0 in libvdr-skinflatplus.so.2.6.6[7fdd38543000+a0000]
Mär 31 10:56:34 MLD6-WZ systemd[1]: vdr.service: Main process exited, code=killed, status=8/FPE
Mär 31 10:56:34 MLD6-WZ systemd[1]: vdr.service: Failed with result 'signal'.
Mär 31 10:56:34 MLD6-WZ systemd[1]: vdr.service: Scheduled restart job, restart counter is at 3.
Mär 31 10:56:34 MLD6-WZ systemd[1]: Stopped Video Disk Recorder.
Mär 31 10:56:34 MLD6-WZ systemd[1]: Starting Video Disk Recorder...
Mär 31 10:56:34 MLD6-WZ run.sh[8347]: Wait for streamdev server:
Mär 31 10:56:34 MLD6-WZ run.sh[8347]: Get channellist from server:
Mär 31 10:56:35 MLD6-WZ run.sh[8526]: 0
Mär 31 10:56:35 MLD6-WZ vdr[8536]: [8536] VDR version 2.6.6 started

2., Aufnahmen vom Server werden mit Avahi-Linker nicht angezeigt. Was für mich das wichtigste Argument wäre.
Hier habe ich alle Tipps aus dem Wiki umgesetzt.
=mld6]https://www.minidvblinux.de/wiki/mld/addons_und_plugins/avahi-linker?s[]=mld6
Code: [Select]
root@MLD6-WZ:~# exportfs -av
exporting *:/data

Code: [Select]
root@MLD6-WZ:~# showmount -e 192.168.1.106
Export list for 192.168.1.106:
/data *

3., Auch im Menu werden keine Aufnahmen vom Server angezeigt. WEenn ich eine Aufnahme programmieren will, kann ich als Ziel auch den Server nicht auswählen.

Anbei noch ein Support Log id ist: scjlOt

Grüße
strike

« Last Edit: March 31, 2024, 22:42:22 by strike »
VDR1: MSI H110M ECO, 1x Cine S2 Rev 7.0A mit Duoflex, 1x Duoflex CI, MLD 5.5 testing
VDR2: ThinkCentre M720q MLD 6.4 - Alpha

Offline strike

  • Member
  • **
  • Posts: 64
    • View Profile
Test MLD-6.4 mit ThinkCentre M720q by strike
« Reply #1 on: April 02, 2024, 20:53:35 »
Hallo,

Hier ein grep nach error.

Code: [Select]
journalctl |grep -i error
Apr 02 20:11:26 MLD6-WZ avahi-daemon[717]: /hosts:1: Error, unexpected end of line!
Apr 02 20:11:27 MLD6-WZ vdr[926]: [942] live: ERROR: Unable to load cert/key (/etc/vdr/plugins/live/live.pem / /etc/vdr/plugins/live/live-key.pem): No such file or directory
Apr 02 20:11:31 MLD6-WZ vdr[926]: [926] ERROR: streamdev-client: Couldn't connect to 192.168.1.4:2004: Connection timed out
Apr 02 20:11:32 MLD6-WZ vdr[926]: [926] ERROR: EpgSync: Unable to connect to Server
Apr 02 20:11:34 MLD6-WZ NetworkManager[667]: <warn>  [1712081494.7981] dns-sd-resolved[48818209020d28cf]: send-updates SetLinkDomains@2 failed: GDBus.Error:org.freedesktop.resolve1.LinkBusy: Link eth0 is managed.
Apr 02 20:11:36 MLD6-WZ setting[1023]: TypeError: settings.system.announce is not a function
Apr 02 20:11:36 MLD6-WZ Xserver[1206]:         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
Apr 02 20:11:36 MLD6-WZ Xserver[1222]: Errors from xkbcomp are not fatal to the X server
Apr 02 20:11:36 MLD6-WZ Xserver[1224]: Errors from xkbcomp are not fatal to the X server
Apr 02 20:11:46 MLD6-WZ vdr[926]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:11:50 MLD6-WZ vdr[926]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:11:55 MLD6-WZ vdr[926]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:11:55 MLD6-WZ vdr[926]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:12:29 MLD6-WZ vdr[926]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:14:24 MLD6-WZ vdr[926]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:14:24 MLD6-WZ vdr[926]: audio/alsa: writei underrun error? 'Broken pipe'
Apr 02 20:15:41 MLD6-WZ vdr[926]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:15:41 MLD6-WZ vdr[926]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:36:38 MLD6-WZ vdr[926]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:36:44 MLD6-WZ kernel: Restfulapi Serv[952]: segfault at 7f96b6300c70 ip 00007f96b6300c70 sp 00007f967effbec8 error 15 in libstdc++.so.6.0.29[7f96b62fe000+b000]
Apr 02 20:36:45 MLD6-WZ vdr[1855]: [1879] live: ERROR: Unable to load cert/key (/etc/vdr/plugins/live/live.pem / /etc/vdr/plugins/live/live-key.pem): No such file or directory
Apr 02 20:36:45 MLD6-WZ vdr[1855]: [1855] ERROR: attempt to open OSD while it is already open - using dummy OSD!
Apr 02 20:36:46 MLD6-WZ kernel: Restfulapi Serv[1882]: segfault at 7fe73af0ac70 ip 00007fe73af0ac70 sp 00007fe6d6ffbec8 error 15 in libstdc++.so.6.0.29[7fe73af08000+b000]
Apr 02 20:37:48 MLD6-WZ vdr[2277]: [2301] live: ERROR: Unable to load cert/key (/etc/vdr/plugins/live/live.pem / /etc/vdr/plugins/live/live-key.pem): No such file or directory
Apr 02 20:37:48 MLD6-WZ vdr[2277]: [2277] ERROR: attempt to open OSD while it is already open - using dummy OSD!
Apr 02 20:37:50 MLD6-WZ vdr[2277]: [2277] ERROR: attempt to open OSD while it is already open - using dummy OSD!
Apr 02 20:37:50 MLD6-WZ vdr[2277]: [2277] ERROR: attempt to open OSD while it is already open - using dummy OSD!
Apr 02 20:37:53 MLD6-WZ vdr[2277]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:37:54 MLD6-WZ vdr[2277]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:38:06 MLD6-WZ vdr[2277]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:38:13 MLD6-WZ vdr[2277]: audio/alsa: wait underrun error? 'Broken pipe'
Apr 02 20:38:15 MLD6-WZ vdr[2277]: audio/alsa: wait underrun error? 'Broken pipe'
VDR1: MSI H110M ECO, 1x Cine S2 Rev 7.0A mit Duoflex, 1x Duoflex CI, MLD 5.5 testing
VDR2: ThinkCentre M720q MLD 6.4 - Alpha

Offline strike

  • Member
  • **
  • Posts: 64
    • View Profile
Test MLD-6.4 mit ThinkCentre M720q by strike
« Reply #2 on: April 15, 2024, 21:59:20 »
Hallo,

Hat etwas gedauert, aber ich habe es hinbekommen  :)
Quote
2., Aufnahmen vom Server werden mit Avahi-Linker nicht angezeigt. Was für mich das wichtigste Argument wäre.
Hier habe ich alle Tipps aus dem Wiki umgesetzt.
=mld6]https://www.minidvblinux.de/wiki/mld/addons_und_plugins/avahi-linker?s[]=mld6

Hier hatte ich ein DNS Problem. MLD-MSI-Server ist der Name meines Servers mit MLD 5.5 testing.
Code: [Select]
ping MLD-MSI-Server
ping: bad address 'MLD-MSI-Server'

Das Eintragen des Servers in die /etc/hosts brachte die Lösung.

Code: [Select]
root@MLD6-WZ:~# ping MLD-MSI-Server
PING MLD-MSI-Server (192.168.1.4): 56 data bytes
64 bytes from 192.168.1.4: seq=0 ttl=64 time=0.285 ms
64 bytes from 192.168.1.4: seq=1 ttl=64 time=0.476 ms
64 bytes from 192.168.1.4: seq=2 ttl=64 time=0.487 ms
^C
--- MLD-MSI-Server ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.285/0.416/0.487 ms

Nach einem Neustart wurde die Aufnahmen angezeigt. Prima, jetzt kann ich weiter testen  :)

Quote
3., Auch im Menu werden keine Aufnahmen vom Server angezeigt. Wenn ich eine Aufnahme programmieren will, kann ich als Ziel auch den Server nicht auswählen.

Auch das wurde durch den DNS-Eintrag gelöst.

Was mir noch aufgefallen ist.
Ich habe schon seit Jahren den Startkanal auf ZDF eingestellt.
Wenn der VDR hochfährt startet er mit ARD (erster Kanal in der Kanalliste)
Wenn der VDR neu gestartet wird, egal ob über Menu oder Terminal, dann startet er mit dem Eintrag aus dem VDR Setup, bei mir ZDF

Grüße
strike
VDR1: MSI H110M ECO, 1x Cine S2 Rev 7.0A mit Duoflex, 1x Duoflex CI, MLD 5.5 testing
VDR2: ThinkCentre M720q MLD 6.4 - Alpha

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 20164
    • View Profile
    • ClausMuus.de
Test MLD-6.4 mit ThinkCentre M720q by strike
« Reply #3 on: April 15, 2024, 22:05:41 »
Bei mir startet der VDR immer mit dem eingestellten Kanal.
Liefert Dein DVB Empfänger eventuell erst mit Verzögerung ein Signal, bzw. lässt sich erst verzögert tunen? Dann würde der VDR beim booten auf dem ersten Kanal hängen bleiben.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline strike

  • Member
  • **
  • Posts: 64
    • View Profile
Test MLD-6.4 mit ThinkCentre M720q by strike
« Reply #4 on: April 15, 2024, 22:11:35 »
Ist ein Stream-Client, hat also keine DVB-Karte.

Aber das könnte evtl. damit zutun haben.
Code: [Select]
root@MLD6-WZ:~# journalctl -u vdr |grep -i error
Apr 15 21:45:34 MLD6-WZ vdr[926]: [926] ERROR: streamdev-client: Couldn't connect to 192.168.1.4:2004: Network is unreachable
Apr 15 21:45:34 MLD6-WZ vdr[926]: [960] ERROR (svdrp.c,253): Network is unreachable
Apr 15 21:45:34 MLD6-WZ vdr[926]: [926] ERROR: EpgSync: Unable to connect to Server

Ich kann aber alle Sender tunen, bzw. streamen, auch der EPG wird gesynct.
VDR1: MSI H110M ECO, 1x Cine S2 Rev 7.0A mit Duoflex, 1x Duoflex CI, MLD 5.5 testing
VDR2: ThinkCentre M720q MLD 6.4 - Alpha

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 20164
    • View Profile
    • ClausMuus.de
Test MLD-6.4 mit ThinkCentre M720q by strike
« Reply #5 on: April 15, 2024, 22:14:40 »
Ja, aber halt eventuell erst ein paar Sekunden nach dem Booten.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

[1] MLD-6.x / General / Test MLD-6.4 mit ThinkCentre M720q by strike
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.