[1] MLD-5.x / General / ACPI Wakeup / Nächste Timerzeit
 

Offline ThomasP

  • Member
  • **
  • Posts: 59
    • View Profile
ACPI Wakeup / Nächste Timerzeit
« on: January 05, 2024, 12:54:49 »
Hallo,

ich habe mir (endlich) wieder einen (fast) funktionsfähigen VDR mit MLD installiert. Es funktioniert alles soweit, bis auf den Wakeup für den nächsten Timer. Ich habe mittels dieses Testscript versucht, ob der Rechner überhaupt aus dem Sleep aufwacht, aber das macht er leider nicht (http://www.vdr-wiki.de/wiki/index.php/ACPI_Wakeup).

Ich habe es auch mit dem zweimaligen setzen des Timers probiert, auch das funktioniert leider nicht.

Setzte ich den Timer im Bios, wacht das System auf. Ich habe es mit und ohne aktiviertem Timer im Bios probiert. Leider kein Erfolg. Da das System zumindest per WOL aufwacht, habe ich mir überlegt, dieses Funktion nach extern zu verlagern, da ich ohnehin einen Server permanent laufen habe.

Meine Frage:
- Gibt es eventuell noch eine Idee für den ACPI - Wakeup?
- Im Zweifel würde ich unter /etc/vdr/shutdown.d ein Skript hinterlegen, welches die nächste "Timerzeit" an meinen Server übermitteln, damit von da der WOL ausgeführt wird. (Gibt es da eventuell auch schon was einfacheres?)
MLD 5.5 - Sundtek Twin USB Sat - 8GB RAM - 512GB HDD - HP ProDesk 600 G2 + Kodi Clients (Pi + FireTV) per VNSI

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 20058
    • View Profile
    • ClausMuus.de
ACPI Wakeup / Nächste Timerzeit
« Reply #1 on: January 05, 2024, 16:49:51 »
Hast Du's mal mit der nvram Wakeup Methode versucht, oder mit einem Reboot nach dem Setzen der Aufwachzeit? Beides kannst Du im Setup unter "Standby" einstellen. Vor allem bei älteren Mainbords (älter als 15 Jahre) funktioniert die acpi Methode oft nicht.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline franky

  • Profi Member
  • ****
  • Posts: 364
    • View Profile
ACPI Wakeup / Nächste Timerzeit
« Reply #2 on: January 06, 2024, 09:35:27 »
Wichtig ist auch die Konfiguration im BIOS.
Dort muss "RTC Power On", meist unter "Advanced - ACPI Configuration" zu finden, auf "BY OS" gesetzt sein.

Offline ThomasP

  • Member
  • **
  • Posts: 59
    • View Profile
ACPI Wakeup / Nächste Timerzeit
« Reply #3 on: January 07, 2024, 12:21:16 »
Unterhalb von Standby habe ich nur die Möglichkeit die "Inaktivitätszeit" des VDRs für den Shutdown zu definieren, aber keine Einträge zu nvram oder restart. Fehlt hier eventl. noch die Installation eines Paketes? Ich habe die 5.4 stable installiert.
Der Rechner ist zwar gebraucht, aber eigentlich nicht so alt (>= 15 Jahre). (HP ProDesk 600 G2, Pentium G4400, also maximal 9 Jahre, eher jünger). Vom der Bios Optik auch eher neuer, vermutlich UEFI-Konfiguration?
Die RTC-Option haben ich soweit auch nicht. Ich kann beim Powermanagement noch so etwas wie "S5" aktivieren, aber so wie ich das interpretiere, ist das eher ein "noch tieferer Schlaf" und damit vermutlich auch eher kontraproduktiv?

Es gibt noch ein Paket "suspend", welches ich noch nicht installiert habe. Unter System, ist der ACPI-Daemon aktiviert, falls es damit noch zusammenhängen kann.
MLD 5.5 - Sundtek Twin USB Sat - 8GB RAM - 512GB HDD - HP ProDesk 600 G2 + Kodi Clients (Pi + FireTV) per VNSI

Offline franky

  • Profi Member
  • ****
  • Posts: 364
    • View Profile
ACPI Wakeup / Nächste Timerzeit
« Reply #4 on: January 07, 2024, 12:49:48 »
Hallo,

du hattest doch in deinem 1. Beitrag geschrieben:
"Setzte ich den Timer im Bios, wacht das System auf."

Das bedeutet ja, dass Du eine Option für den "RTC-Wakeup" im Bios hast.
Evtl. hat diese Bios-Option eine andere Bezeichnung.
Diese Option darf nur nicht auf "enabled" stehen.
Da sollte anstatt "enabled" so was ähnliches wie "By OS" auswählbar sein.
Wenn nur "enabled" oder "disabled" auswählbar ist, mal "disabled" probieren.
Mit enabled funktioniert acpi wakeup auf keinen Fall.

Dein System mit G4400 sollte auf jeden Fall acpi wakeup unterstützen.

Die einzigen Systeme bei denen ich mal nvram nutzen musste, waren vor 15 Jahren ION1-Systeme.

Die Konfiguration von nvram wakeup ist auch nicht bei jedem System möglich und mit einer relativ komplizierten Anlernmethode verbunden.
Dabei wird dann das "aufruf Argument" ermittelt, das man dann im Webif unter Standby eingeben muss.
Es reicht nicht dort einfach nvram anstatt acpi auszuwählen.

Die Systemzeit im Bios (RTC) sollte auch immer auf UTC (nicht lokale Zeit) stehen damit acpi Wakeup korrekt funktioniert.


Offline franky

  • Profi Member
  • ****
  • Posts: 364
    • View Profile
ACPI Wakeup / Nächste Timerzeit
« Reply #5 on: January 07, 2024, 13:54:50 »
Ich habe mich mal über den HP ProDesk 600 G2 informiert.
Das System hat ja das spezielle HP-Bios.
Ich habe ein ProBook mit i5 der 8. CoreI Generation mit ähnlichem Bios.
Da kann man tatsächlich nur den RTC-Wakaup je Wochentag durch abhaken aktivieren.
Ich vermute mal, wenn kein Tag abgehakt ist, ist der RTC-Wakeup deaktiviert.

Ich könnte mal die 5.5 (5.4 geht wegen der GPU nicht) auf einem Stick installieren und den Wakeup bei meinem Notebook testen.

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 20058
    • View Profile
    • ClausMuus.de
ACPI Wakeup / Nächste Timerzeit
« Reply #6 on: January 07, 2024, 14:58:08 »
Das Standby Paket darfst Du nicht installieren. Aber das Wakeup Paket muss installiert sein (ist im nightbuild Image aber bereits enthalten.)
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline ThomasP

  • Member
  • **
  • Posts: 59
    • View Profile
ACPI Wakeup / Nächste Timerzeit
« Reply #7 on: January 07, 2024, 14:59:16 »
Ja, es lässt sich Stunde und Minute einstellen und der Tag aktivieren (Mo-So).
Leider keine Option mit RTC / enable / disable / byOS. Wenn ich das so im BIOS aktivieren, dann wacht er auf, wenn ich die Tage wieder disable und den Rechner mit einem gesetzten Timer schlafen lege, dann wacht er wieder nicht auf.
Ich hatte das ganze auch schon mit diesem Skript probiert und leider auch keinen Erfolg: http://www.vdr-wiki.de/wiki/index.php/ACPI_Wakeup;;


MLD 5.5 - Sundtek Twin USB Sat - 8GB RAM - 512GB HDD - HP ProDesk 600 G2 + Kodi Clients (Pi + FireTV) per VNSI

Offline franky

  • Profi Member
  • ****
  • Posts: 364
    • View Profile
ACPI Wakeup / Nächste Timerzeit
« Reply #8 on: January 07, 2024, 18:04:14 »
Ich habe jetzt mal acpi wakeup bei meinem HP ProBook mit i5-8250U und HP-Bios getestet.
Die UHD GPU funktioniert nicht mit der MLD5.4 stable, weshalb ich die MLD 5.5 testing verwendet habe.
Zuerst hatte ich übersehen, dass der System-Stick mit MLD 5.5 testing, den ich auf einem meiner Intel-MiniPCs als Client mit streamdev-client installiert und konfiguriert hatte, ja die Aufnahme-Timer auf dem streamdev-Server anlegt. ???
Nachdem ich das Anlegen des Timer auf dem Server deaktiviert hatte, hat der 1. Versuch mit lokalem Timer aber auch nicht funktioniert.
Ich habe dann im Bios "DeepSleep" deaktiviert und der nächste acpi wakeup Timer hat funktioniert.
Mittlerweile hatte ich eine weiter Aufnahme programmiert, für die das System auch aufgewacht ist.

Im Bios ist unter "Geplanter Systemstart" keiner der Wochentage angehakt und Stunde und Minute stehen auf 0, ansonsten ist abweichend von den Default-Einstellungen nur noch  des "Deep sleep" unter "Power Management Options" deaktiviert.
Systemzeit im Bios läuft auf UTC (Lokale Zeit -1h).

Versuche es mal mit der MLD5.5 testing auf deinem System.
Lässt sich ja recht schnell auf einem USB-Stick installieren.
Die HD510 Intel GPU deines Pentium G4400 funktioniert auch mit MLD 5.5 einwandfrei.

Nachtrag:
Hier noch ein paar meiner Bios-Einstellung, die eigentlich keinen Einfluss auf ACPI-Wakeup haben sollten.
Bei den "Power Management Options"
"Wake on USB" aktiviert
"Power Control" deaktiviert
Bei den "Boot Optionen"
"Schnelles booten (Fastboot)" deaktiviert
Bei "Secure Boot-Konfiguration"
"Aktivieren der Legacy-Unterstützung und Deaktivieren von Secure Boot"
« Last Edit: January 07, 2024, 19:00:34 by franky »

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 20058
    • View Profile
    • ClausMuus.de
ACPI Wakeup / Nächste Timerzeit
« Reply #9 on: January 08, 2024, 19:30:30 »
Also solange im Setup unter Suspend die Wakeup Methode nicht auswählbar ist, ist das wakeup Paket nicht installiert, und das Aufwecken wird nicht funktionieren.
Als nächstes ist zu beachten, dass Du beim Test einen Timer anlegen solltest, der mindestens 5 Minuten in der Zukunft liegt, damit genug Zeit zwischen Programmieren, herunterfahren und aufwecken liegt.
Wegen Deiner Tests mit irgendwelchen Test Skripten musst Du aufpassen, dass diese auch berücksichtigen, dass Deine Bios Uhr in UTC läuft. Wenn die Skripte das nicht berücksichtigen werden die nicht funktionieren.
MLD 5.5 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.5 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 12TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline ThomasP

  • Member
  • **
  • Posts: 59
    • View Profile
ACPI Wakeup / Nächste Timerzeit
« Reply #10 on: January 08, 2024, 20:28:01 »
Ich habe nochmal die Testing auf einen USB Stick gezogen und siehe da, der Rechner wacht bei jedem Timer auf. Jetzt sehe ich auch die genannten Einstellungen für nvram-wakup unter "standby". (Habe aber nichts anpassen müssen. Es lief out-of-the-box.
Im Bios habe ich nichts weiter geändert, außer halt, die Haken bei den Wochentage zu entfernen. Die Einstellung "deep sleep", habe ich in den Powermanagement Options auch nicht. Der PC lief von Anfang an auf UTC Time.
Ich habe direkt die 5.5 Testing auf dem Rechner installiert und mehrere Timer haben seit gestern den VDR sauber gestartet. Es muss irgendwie an der 5.4. stable oder meiner Installation gelegen haben. Ich habe aber auch keine Fehlermeldungen gesehen.

Vielen Danke für eure Hilfe und die ganzen Tipps!
MLD 5.5 - Sundtek Twin USB Sat - 8GB RAM - 512GB HDD - HP ProDesk 600 G2 + Kodi Clients (Pi + FireTV) per VNSI

Offline linuxdxs

  • Member
  • **
  • Posts: 58
    • View Profile
ACPI Wakeup / Nächste Timerzeit
« Reply #11 on: January 13, 2024, 20:26:21 »
Ich habe folgendes Bashskript mit -s an den Programmaufruf angehängt

#! /bin/bash

DEV=/sys/class/rtc/rtc0/wakealarm
#DEV=/proc/acpi/alarm              # Fuer Kernel < 2.6.22

#ACPI
echo "Arguments:  $*"
#echo "Next timer: $1 seconds from 1970/01/01, UTC"  >> /home/test
#echo "Next timer: $2 seconds from now" >> /home/test

naechsterTimer=$(/bin/date --date "now +$2 seconds" "+%s")
#naechsterTimer=$(/bin/date --date "now +$2 seconds" "+%Y-%m-%d %H:%M:%S")# Fuer Kernel < 2.6.22
echo $naechsterTimer
sudo chmod a+wr  $DEV

# wakealarm löschen (wenn schon gesetzt, muss er gelöscht werden)
echo 0 >  $DEV
#alarm setzen
echo $naechsterTimer > $DEV
#echo $naechsterTimer > $DEV

sudo /sbin/shutdown -h now
EXITSTATUS=0
exit $EXITSTATUS


[1] MLD-5.x / General / ACPI Wakeup / Nächste Timerzeit
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.