[1] 2 >>> MLD-5.x / Systems / Raspberry PI / MLD 5.4 erkennt TechnoTrend Connect S2-4600 nicht, MLD 5.3 bootet nicht
 

Offline linuxtux1982

  • Newbie
  • *
  • Posts: 12
    • View Profile
Hallo zusammen,

ich habe MLD 5.4 auf meinem Raspberry Pi 3 installiert. Ich bekomme aber leider meinen DVB-S Receiver nicht zum laufen TechnoTrend Connect S2-4600. Ich have DVB Autodetect installiert. Der Treiber wird aber scheinbar nicht geladen.


cpu:
                       CPU
                       CPU
                       CPU
                       CPU
keyboard:
                       Logitech Unifying Receiver
mouse:
                       Logitech Unifying Receiver
network:
  wlan0                Broadcom BCM43430 WLAN card
  eth0                 Standard Microsystems Ethernet controller
network interface:
  eth0                 Ethernet network interface
  wlan0                WLAN network interface
  lo                   Loopback network interface
  ip6tnl0              Network Interface
  ip6_vti0             Network Interface
  sit0                 Network Interface
disk:
  /dev/ram11           Disk
  /dev/ram2            Disk
  /dev/ram0            Disk
  /dev/ram9            Disk
  /dev/ram7            Disk
  /dev/ram14           Disk
  /dev/ram5            Disk
  /dev/ram12           Disk
  /dev/ram3            Disk
  /dev/ram10           Disk
  /dev/ram1            Disk
  /dev/sda             SanDisk Ultra
  /dev/ram8            Disk
  /dev/ram15           Disk
  /dev/ram6            Disk
  /dev/mmcblk0         Disk
  /dev/ram13           Disk
  /dev/ram4            Disk
partition:
  /dev/sda1            Partition
  /dev/mmcblk0p1       Partition
  /dev/mmcblk0p2       Partition
  /dev/mmcblk0p3       Partition
usb controller:
                       ARM USB 0
hub:
                       Linux Foundation 2.0 root hub
                       Standard Microsystems USB 2.0 Hub
                       Standard Microsystems USB 2.0 Hub
memory:
                       Main Memory
unknown:
                       Broadcom BCM43430 WLAN card
                       Broadcom BCM43430 WLAN card
                       TechnoTrend TT-connect S2-4600
                       Logitech Unifying Receiver

Ich habe auch probiert, die 5.3 (21.504kb??) zu verwenden, aber das Image startet leider nicht. Die 5.4 (89.088kB) funktioniert. Ist das Image der 5.3 defekt? Ichhabe es mehrfach heruntergeladen. Leider ist hier keine Checksumme/Hash angegeben..


Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18091
    • View Profile
    • ClausMuus.de
Die Größe vom 5.3 Image passt schon. Das ist wesentlich kleiner, weil da noch ein einfacherer Installer dabei war. Da das Image seit Jahren nicht mehr geändert wurde, glaube ich auch nicht das dieses kaputt ist.

Magst Du mal ein Debug-Log erstellen, damit wir sehen können welche Pakete Du installiert hast.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline linuxtux1982

  • Newbie
  • *
  • Posts: 12
    • View Profile
Ich habe gerade das Debug-Log erstellt (Code: Ns4asZ)
aus der hwinfo:
unknown:
                       Broadcom BCM43430 WLAN card
                       Broadcom BCM43430 WLAN card
                       TechnoTrend TT-connect S2-4600
                       Logitech Unifying Receiver

"unknown" - das könnte das Problem sein.

Ich habe auch schon google befragt.
Es gibt wohl eine spezielle Firmware: dvb-demod-m88ds3103.fw
Mir ist nur noch nicht klar wie ich diese flashen kann....

Offline NoTape

  • Member
  • **
  • Posts: 63
    • View Profile
...
Es gibt wohl eine spezielle Firmware: dvb-demod-m88ds3103.fw
Mir ist nur noch nicht klar wie ich diese flashen kann....

Die Firmware muss nicht geflasht werden.
Sie wird nur unter /lib/firmware/ abgelegt und automatisch in das Gerät geladen.

NoTape
VDR1: MLD-5.4 testing * ASRock FM2A88X-ITX+ * Dual Core AMD A4-6300 * GeForce GT 520 * DVB-C Hauppauge WinTV-dualHD
VDR2: MLD-5.4 testing * ASUS M5A78L * AMD FX-4300 * MSI GT1030 Silent * SDC Megtron 240x128 * BOBLIGHT * DVB-T2 Hauppauge WinTV-dualHD
VDR3: MLD-5.4 testing * Intel NUC6i3SYH * Dual Core i3-6100U mit HD Graphics 520 * DVB-T2 OPTI-Combo USB Stick

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18091
    • View Profile
    • ClausMuus.de
Also, so wie ich das Log verstehe, wurde der Treiber geladen, dann aber festgestellt, dass die exakte ID der DVB Karte unbekannt ist "m88ds3103 3-0068: Unknown device. Chip_id=0f", weswegen die Firmware nicht geladen wurde und die Karte niht verwendet werden kann:
Code: [Select]
...
[  117.676127] dw2102: su3000_identify_state
[  117.676155] dvb-usb: found a 'TechnoTrend TT-connect S2-4600' in warm state.
[  117.676185] dw2102: su3000_power_ctrl: 1, initialized 0
[  117.678049] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[  117.682677] dvbdev: DVB: registering new adapter (TechnoTrend TT-connect S2-4600)
[  117.691876] dvb-usb: MAC address: 00:18:bd:5b:db:1e
[  118.021191] Invalid probe, probably not a DS3000
[  118.028804] m88ds3103 3-0068: Unknown device. Chip_id=0f
[  118.028895] dvb-usb: no frontend was attached by 'TechnoTrend TT-connect S2-4600'
[  118.029223] Registered IR keymap rc-tt-1500
[  118.029329] rc rc0: TechnoTrend TT-connect S2-4600 as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.2/rc/rc0
[  118.029621] input: TechnoTrend TT-connect S2-4600 as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.2/rc/rc0/input1
[  118.029863] dvb-usb: schedule remote query interval to 250 msecs.
[  118.029887] dw2102: su3000_power_ctrl: 0, initialized 1
[  118.029892] dvb-usb: TechnoTrend TT-connect S2-4600 successfully initialized and connected.
[  118.030016] usbcore: registered new interface driver dw2102
...
Mit anderen Worten: Für Deine Karte gibt es keinen Treiber.
« Last Edit: May 05, 2019, 14:52:46 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline NoTape

  • Member
  • **
  • Posts: 63
    • View Profile
...
Mit anderen Worten: Für Deine Karte gibt es keinen Treiber.

Das deckt sich auch mit "linuxtv.org" - danach gibt es zurzeit wohl keine Unterstützung für neuere Geräte - siehe Absatz "Update" unter
https://www.linuxtv.org/wiki/index.php/TechnoTrend_TT-connect_S2-4600
VDR1: MLD-5.4 testing * ASRock FM2A88X-ITX+ * Dual Core AMD A4-6300 * GeForce GT 520 * DVB-C Hauppauge WinTV-dualHD
VDR2: MLD-5.4 testing * ASUS M5A78L * AMD FX-4300 * MSI GT1030 Silent * SDC Megtron 240x128 * BOBLIGHT * DVB-T2 Hauppauge WinTV-dualHD
VDR3: MLD-5.4 testing * Intel NUC6i3SYH * Dual Core i3-6100U mit HD Graphics 520 * DVB-T2 OPTI-Combo USB Stick

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18091
    • View Profile
    • ClausMuus.de
Ich hab den Treiber jetzt einfach mal so geändert, dass er auch diese Karte akzeptiert. Ich habe zwar keine große Hoffnung das dies funktioniert, aber linuxtux1982 kann es ja mal versuchen.
Dafür musst Du auf das unstable dvb Paket updaten.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline linuxtux1982

  • Newbie
  • *
  • Posts: 12
    • View Profile
Das klingt ja nicht so gut..

Ich habe jetzt die Firmwaredatei heruntergeladen:
wget http://palosaari.fi/linux/v4l-dvb/firmware/M88DS3103/3.B/dvb-demod-m88ds3103.fw -O /lib/firmware/dvb-demod-m88ds3103.fw
Ergebnis siehe: OvUv7y (noch keine Funktion...)

Wie kann ich auf das "unstable dvb Paket updaten"?


Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18091
    • View Profile
    • ClausMuus.de
Die Firmware ist sowieso dabei. Es ist wie ich geschrieben habe, das der Treiber Deiner Hardware fehlt.
Um den unstable Test zu machen, musst Du im "Setup / General" auf unstable umstellen. Anschließend kannst Du das dvb Paket aktualisieren (eventuell entfernen und neu installieren).
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline linuxtux1982

  • Newbie
  • *
  • Posts: 12
    • View Profile
Ich habe auf unstable umgestellt und das Paket dvb installiert:
QtKANy

Paket dvb und dvb-autodetect installiert:
bYQ0ET

Die Hardware wird immer noch als unknown angezeigt  :-[

Unter https://www.linuxtv.org/wiki/index.php/TechnoTrend_TT-connect_S2-4600 steht:

"newer (2018) sold revisions of this device with above ID have currently NO support under Linux (vanilla kernels)

tested was a device with ID 0b48:3011 "

Ich habe die  ID 0b48:3011 dann müsste es doch eigentlich gehen-oder nicht?
Kann man den Treiber nicht manuell installieren?

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18091
    • View Profile
    • ClausMuus.de
Nicht die Device ID passt nicht, sondern der auf dem Device verarbeite Chip. Der hat eine ID die vom Treiber nicht unterstützt wird.
Durch meine Anpassung wird jetzt zwar die Firmware geladen, was aber nicht weiter hilft.

Die Karte kann also nicht verwendet werden.
« Last Edit: May 10, 2019, 22:48:37 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline baltic

  • MLD-Debugger
  • Profi Member
  • ****
  • Posts: 442
    • View Profile
Hallo,

ich lese den Artikel so, dass man ihn übersetzen müsste mit:

Seit 2018 verkaufte Revisionen mit der oben genannten ID haben aktuell keinen Linux-Support.

Wenn die HW also ziemlich neu ist, dürftest Du aktuell keine Chance haben.

Gruß
baltic
MLD 5.4 – testing   Asus M3N78-EM  SkyStar2

Offline linuxtux1982

  • Newbie
  • *
  • Posts: 12
    • View Profile
Ich habe eine neue ältere Hardware bei Ebay erstanden.
Diese wird leider immer noch nicht erkannt  :-\

Kann sich das jemand ansehen:
TswwWP

Besten Dank & Gruß

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 18091
    • View Profile
    • ClausMuus.de
Ne, da können wir nichts machen. Da muss TechnoTrend liefern und dann die Kernel Entwickler das gelieferte übernehmen, bevor wir da weiter helfen können. Das wird also bestenfalls noch einige Monate dauern. Wenn Du Pech hast dauert's Jahre oder wird nie gehen.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline linuxtux1982

  • Newbie
  • *
  • Posts: 12
    • View Profile
Gibt es eine Empfehlung bzgl. einer kompatiblen DVB-S Hardware?
Hat die neue Hardware (TswwWP) auch wieder den inkompatiblen Chip? Waran kann ich das erkennen?

[1] 2 >>> MLD-5.x / Systems / Raspberry PI / MLD 5.4 erkennt TechnoTrend Connect S2-4600 nicht, MLD 5.3 bootet nicht
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.