[1] MLD-5.x / Systems / Raspberry PI / MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
 

Offline Tommes

  • Newbie
  • *
  • Posts: 33
    • View Profile
Moin Moin,
Hat jemand zuverlässig MLD am Raspberry Pi mit SATIP (Pi als client) am laufen ?

Ich bin quasi noch in der Einrichtungsphase, vor einigen Wochen unter testing funktionierte es noch einigermaßen, allerdings mit Aussetzern in den Aufnahmen
Nun bricht die Aufnahme nach wenigen Sekunden ab.

Verwendete Hardware:

- RPI 3B+ mit orignal RPI Netzteil
- Telestar Digibit R1 (FW offizielle 1.25.0.157; sowie satip-axe build 15 getestet)
- Speicherort Aufnahmen: NAS
- Betrieb über LAN

Live-TV funktioniert unter der offiziellen Firmware im Digibit recht gut, Umschaltzeiten gehen auch noch.
Unter satip-axe bekomme ich teilweise keinen Lock, sprich kein Bild. ich glaube das war bei HD Sendern
der Fall, SD-Sender gingen mit langen Umschaltzeiten.

Einstellungen im WebIF:
Verwendete Tuner: 1 (da noch im Einrichtbetrieb auch nur einer angeschlossen ist)
SatIP: Übertragung: Unicast / RTP over TCP funktioniert beides gefühlt gleich gut

Muß man evtl. irgenwo noch die eine oder andere Einstellung setzen / Config ändern ?

Bisherige Maßnahmen, die ich probiert habe:
- RPI Netzteil 2A gegen original RPI NT getauscht
- Netzwerk getestet mit iperf --> RPI <-> RPI = 225-239 mbit/s
- FritzBoxen gegen Switche getauscht

Produktiv-VDRs (easyVDR) mit eigenen DVB Karten speichern ihre Aufnahmen fehlerfrei auf dem NAS

Achso, das LAN sieht wie folgt aus: Stern Verteilung (D-Link 16 Port) mit FritzBox 6490 für Inet & DHCP
Allerdings hängt an einem Sternenzacken ein weiterer Switch (Asus 8 Port) auf dem Dachboden, an dem
der RPI, der Digibit & eine weitere FritzBöx (als Mesh Client) hängt.

Auszug aus dem Log
Code: [Select]
Mar 11 17:52:18 (none) user.err vdr: [1901] ERROR: skipped 187 bytes to sync on start of TS packet at remux.c/Analyze(1713)
Mar 11 17:52:21 (none) user.err vdr: [1830] ERROR: 53189 ring buffer overflows (9999345 bytes dropped)
Mar 11 17:52:23 (none) user.err vdr: [1830] ERROR: 35025 ring buffer overflows (6584700 bytes dropped)
Mar 11 17:52:27 (none) user.err vdr: [1830] ERROR: 50081 ring buffer overflows (9415228 bytes dropped)
Mar 11 17:52:29 (none) user.err vdr: [1830] ERROR: 33092 ring buffer overflows (6221296 bytes dropped)
Mar 11 17:52:33 (none) user.err vdr: [1830] ERROR: 43316 ring buffer overflows (8143408 bytes dropped)
Mar 11 17:52:35 (none) user.err vdr: [1830] ERROR: 36813 ring buffer overflows (6920844 bytes dropped)
Mar 11 17:52:35 (none) user.err vdr: [1830] ERROR: 1 ring buffer overflow (1 bytes dropped)
Mar 11 17:52:39 (none) user.err vdr: [1830] ERROR: 47182 ring buffer overflows (8870216 bytes dropped)
Mar 11 17:52:39 (none) user.err vdr: [3235] ERROR: skipped 187 bytes to sync on start of TS packet at remux.c/Analyze(1713)

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 990
    • View Profile
MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
« Reply #1 on: March 11, 2019, 22:23:50 »
Hi,

worin besteht denn der Unterschied bei der Digibit R1 (Orginal) oder (satip-axe)?

Denn ich habe 2 rpi's (3 Version) als client laufen mit satip-plugin 1. mal OctopusNet 1.mal Fritzbox DVB-C(Kabel) Repeater,
und beides läuft ohne Probleme.

Gruß,
  Roland
« Last Edit: March 11, 2019, 22:31:32 by rfehr »
1x OctopusNet mit 2x DVB-S2 u. 2x DVB-C
1x Zotac ITX-A Atom 330 als Client
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline Tommes

  • Newbie
  • *
  • Posts: 33
    • View Profile
MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
« Reply #2 on: March 13, 2019, 15:27:31 »
Also, wie gesagt, in meiner Umgebung läuft die original Firmware besser

satip axe ist vom gleichen Entwickler wie tv headend, es soll stabiler laufen und der Datenstrom kann von udp auf tcp umgestellt werden.
Desweiteren unterstützt es "minisatip8"

Roland, wo speicherst Du Deine Aufnahmen, direkt an den RPIs oder auch im Netzwerk?

Offline rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 990
    • View Profile
MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
« Reply #3 on: March 13, 2019, 16:07:21 »
Hi Tommes,

ich speicher auf einem NAS.

Gruß,
  Roland
1x OctopusNet mit 2x DVB-S2 u. 2x DVB-C
1x Zotac ITX-A Atom 330 als Client
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
2x RPI3
1x https://www.zotac.com/at/product/mini_pcs/pi335

Offline Tommes

  • Newbie
  • *
  • Posts: 33
    • View Profile
MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
« Reply #4 on: March 14, 2019, 13:04:17 »
Hm, ich habe gerade mal testweise die Fritzbox cable als satip Server verwendet.
Die Problematik mit dem Speichern der Aufnahmen tritt hier genauso auf, allerdings einen Tick später, nach 10 Sekunden hakt es einmal und nach 20 Sekunden reißt die Aufnahme komplett ab.
Scheint also das Problem nicht beim Digibit zu liegen.

Ich werde MLD nochmal komplett neu aufsetzen und dann nochmal Rückmeldung geben.

Offline Tommes

  • Newbie
  • *
  • Posts: 33
    • View Profile
MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
« Reply #5 on: March 15, 2019, 13:04:39 »
Aktueller Status:

Netzwerk Verkabelung ins Dachgeschoss ist fehlerhaft und ist der Verursacher.

Fazit:
Iperf ist daher nur bedingt einsetzbar, um das eigene Netzwerk zu testen, da es bei mir den vollen RPI möglichen Durchsatz gemessen hat.

Offline cervicor

  • Newbie
  • *
  • Posts: 33
    • View Profile
MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
« Reply #6 on: March 15, 2019, 16:14:21 »
Hallo Tommes,

schon mal die QoS-Einstellungen in den Switches geprüft? Ich hatte Aussetzer und Artefakte bei Live TV (HD) und Aufnahmen bis ich merkte, das QoS in meinen Switches ausgeschaltet war. Nun habe ich es eingerichtet und seit dem keine Probleme mehr.

viele Grüße
cervicor
DD Octopus NET V2 S2 Max - SAT>IP-Server
ZBOX C1327 Nano, MLD 5.4 - als Server -
2x Raspi 3, MLD 5.4 - als Clients

Alle Systeme haben "Daten" per NFS auf einem Synology-NAS gemountet

Offline Tommes

  • Newbie
  • *
  • Posts: 33
    • View Profile
MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
« Reply #7 on: March 16, 2019, 09:18:45 »
Qos wird von der meinem Switch (D-Link DGS-1016D) wohl unterstützt, aber man kann da nichts ein- oder ausschalten, da er kein Web IF hat.
In der Fritzbox kann man qos unter Internet - Filter - Priorisierung konfigurieren, habe dem MLD RPI und den Digibit entsprechend konfiguriert, aber keine Besserung.

Weitere Tests und deren Ergebnisse folgen...

Offline Tommes

  • Newbie
  • *
  • Posts: 33
    • View Profile
MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
« Reply #8 on: March 16, 2019, 15:10:41 »
Hm, Aufnahmen auf dem NAS laufen von der Aufnahmedauer her durch, aber nach 2-3 Minuten hakt der Strream und
wird regelrecht zerfleddert.
Eine Test-Aufnahmen auf der SD Karte des RPI läuft einwandfrei.

Das NAS ist eine Seagate Dockstar, mit Debian drauf und USB2.0 Festplatten dran.
Gemountet habe ich es in der fstab
Code: [Select]
//192.168.xxx.xxx/USB-HD/video /data/tv cifs vers=1.0,username="user",password="pass"  0 0

Auf meinen anderen VDRs dagegen mounte ich das NAS erst nach dem Start des VDR

Offline baltic

  • Profi Member
  • ****
  • Posts: 315
    • View Profile
MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
« Reply #9 on: March 16, 2019, 20:01:30 »
Hallo,

cifs ist imho für diese Aufgabenstellung nicht das beste Protokoll.
Versuche es doch mal mit nfs.

Gruß
baltic
MLD 5.4 – testing   Asus M3N78-EM  SkyStar2

[1] MLD-5.x / Systems / Raspberry PI / MLD 5.4 [stable] RPI 3 B plus + SatIP (Digibit R1)
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.