[1] MLD-5.x / General / NAS via nfs als Aufnahmeverzeichnis (data) einbinden, klappt nicht
 

Offline Sven

  • Newbie
  • *
  • Posts: 40
    • View Profile
Hallo allerseits,

nachdem ich mit den Tips aus den bisherigen Beiträgen im Forum erfolglos  durchgearbeitet habe, muss ich Euch doch um Rat fragen.
Wie im Betreff geschrieben, will ich die Aufnahmen von meinem MLD direkt auf ein NAS schreiben lassen.
Der avahi-Linker hat ein share gemappt, aber im Webinterface kann ich es nicht als Speichermedium einhängen.
Die Ausgabe von df ergibt:
Code: [Select]
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda2              9766912   6779144   2050008  77% /
tmp                     506668         8    506660   0% /tmp
run                     506668       676    505992   0% /run
dev                     499916         0    499916   0% /dev
log                     506668       464    506204   0% /var/log
/dev/sda3             42541780     75872  42465908   0% /mnt/sda3
/dev/sda3             42541780     75872  42465908   0% /var/cache
/dev/sda1                96775     14905     81871  15% /boot
192.168.178.109:/data/Aufnahme
                     3902166656 2114070272 1676231104  56% /mnt/192.168.178.109__data_Aufnahme

Meine /etc/fstab sieht wie folgt aus:
Code: [Select]
proc        /proc           proc      defaults            0 0
sys         /sys            sysfs     defaults            0 0
run         /run            tmpfs     defaults            0 0
tmp         /tmp            tmpfs     defaults            0 0
dev         /dev            devtmpfs  defaults            0 0
devpts      /dev/pts        devpts    mode=0620,gid=5     0 0
/dev/dvd    /media/dvd      auto      ro,noauto           0 0
/dev/cdrom  /media/cdrom    auto      ro,noauto           0 0
UUID=31fe3735-3efb-4ffd-bdcb-389e68f73d5e  /  auto  defaults  0 1
UUID=439a1274-58c9-4729-8035-794c6c74141d  /mnt/sda3  auto  defaults  0 2
/mnt/sda3/.cache  /var/cache  none  bind  0 0
UUID=8894-13B7  /boot  auto  defaults  0 2

192.168.178.109:/data/Aufnahme  /mnt/192.168.178.109__data_Aufnahme  nfs  bg  0 0
/mnt/192.168.178.109__data_Aufnahme:/mnt/sda3  /data  mergerfs  defaults,category.create=mfs,direct_io,use_ino  0 0


Wenn ich versuche, das share vom NAS "192.168.178.109__data_Aufnahme" im Webinterface als Speichermedium zu speichern bekomme ich folgende Ausgabe:
Code: [Select]
mount.nfs: mount point /mnt/Aufnahme does not exist
mount: mounting fileserver3:/data/Aufnahme on /mnt/Aufnahme failed: No such file or directory
can not mount device Aufnahme
failed
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option
mount: mounting /mnt/192.168.178.102__data_Aufnahme:/mnt/sda3:/mnt/Aufnahme on /data failed: No such device
Der MLD stolpert u.a. noch über eine alte Freigabe, die nicht mehr da ist. Auch der Verweis auf /mnt/sda3 in der /data-Zeile der fstab kommt mir komisch vor. Ich habe den Eindruck, dass ich mir da irgendetwas gründlich zerschossen habe, komme aber aus der Sackgasse nicht mehr heraus.

Die Debug Codes sind unter Yl6JvX zu finden.

Hat jemand eine gute Idee?


Der Vollständigkeit halber, will ich noch hinzufügen, dass der MLD als Server in einer virtuellen Maschine läuft, obwohl ich nicht glaube, dass das mit dem momentanen Problem zu tun hat.

Liebe Grüße
Sven
Sat>IP Server: Grundig GSS DSI 400,
Intel NUC-Kit i3-7100U 2.4GHz HD620 NUC7I3BNH (mit MLD in virtueller Maschine)

Client:
Intel NUC i7-8559U in NUC8i7BEH via KODI

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17405
    • View Profile
    • ClausMuus.de
Zum einen brauchst Du im Webif nichts mehr einstellen, da Diene fstab ja bereits vollständig ist. Da ich den avahilinker nichts nutze kann ich nicht sagen ob Deine Probleme irgendwie damit zusammen hängen. Ich benutze immer nur das nfs-client Paket.
Zum anderen enthält Dein /data Ordner wohl bereits Daten. Dadurch ist der mergerfs Mount dort hin nicht mehr möglich. Du musst also zuerst dafür sorgen das dieser Ordner leer ist. Pass aber auf, dass zu dem Zeitpunkt wo Du den leerst nicht bereits irgendwas dahin gemountet ist.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Sven

  • Newbie
  • *
  • Posts: 40
    • View Profile
Hallo Claus,
vielen Dank für die schnelle Antwort. Nur nochmal zum Verständnis. Heißt das, dass in der fstab der /data-mount vor dem nfs-mount stehen muss, damit der /mnt-Ordner noch leer ist, wenn er zum data-Ordner weiterverarbeitet wird?

Denn wenn schon Aufnahmen im Verzeichnis sind, ist es nicht mehr leer, wenn das share nach /mnt/xyz gemappt ist.

Gruß
Sven
Sat>IP Server: Grundig GSS DSI 400,
Intel NUC-Kit i3-7100U 2.4GHz HD620 NUC7I3BNH (mit MLD in virtueller Maschine)

Client:
Intel NUC i7-8559U in NUC8i7BEH via KODI

Offline clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17405
    • View Profile
    • ClausMuus.de
Nein. Der /data Ordner muss leer sein bevor der mergerfs Mount dorthin geschieht. Gemeint ist damit also der /data Ordner auf der /dev/sda2 Partition, also dem root Laufwerk.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] MLD-5.x / General / NAS via nfs als Aufnahmeverzeichnis (data) einbinden, klappt nicht
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.