[1] MLD-5.x / Systems / Raspberry PI / [5.4 stable] Rasp Pi 3 - CIFS / Samba mounten
 

Offline Tommes

  • Newbie
  • *
  • Posts: 12
    • View Profile
[5.4 stable] Rasp Pi 3 - CIFS / Samba mounten
« on: September 11, 2018, 22:36:14 »
Moin Claus,

ich bin gerade dabei, meinen Pi3 zum Leben zu erwecken.
Leider wollte CIFS nicht klappen, als ich mein NAS einbinden wollte
Pakete cifs & smbclient habe ich bereits installiert

Code: [Select]
MLD> mount -t cifs //192.168.1.1/mein_nas/video /data/tv
Password for root@//192.168.1.1/mein_nas/video:
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount: mounting //192.168.1.1/mein_nas/video on /data/tv failed: No such device

Evtl. kein cifs Support im Kernel ?

Gruß, Tommes

« Last Edit: September 17, 2018, 20:10:16 by Tommes »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
[5.4 stable] Rpi3 - CIFS will nicht
« Reply #1 on: September 11, 2018, 22:56:55 »
Du musst "-o user=" hinzufügen.
Außerdem empfehle ich gerade bei Nezuwerk Mounts die Vorteile vom mergerfs zu nutzen. Nen Mount also nach /mnt/mein_nas durchführen, und dann (über das Webif) per mergerfs zum lokalen Speicher hinzufügen.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Tommes

  • Newbie
  • *
  • Posts: 12
    • View Profile
[5.4 stable] Rpi3 - CIFS will nicht
« Reply #2 on: September 12, 2018, 21:31:46 »
Hm, mit "-o user=" geht es auch nicht
Unter easyvdr mounte genau so nur user & gruppe auf 'vdr' und da klappt es  ???
Code: [Select]
MLD> mkdir /mnt/nas
MLD> mount -t cifs //192.168.1.1/mein_nas/video /mnt/nas -o iocharset=utf8,uid=root,gid=root
Password for root@//192.168.1.1/mein_nas/video:
mount error: cifs filesystem not supported by the system
mount error(19): No such device
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount: mounting //192.168.1.1/mein_nas/video on /mnt/nas failed: No such device
MLD>

Ein
Code: [Select]
cat /proc/filesystems | grep cifs
sagt null, also vom System nicht unterstütztes Filesystem, oder sehe ich das falsch ?
« Last Edit: September 12, 2018, 22:22:39 by Tommes »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
[5.4 stable] Rpi3 - CIFS will nicht
« Reply #3 on: September 13, 2018, 08:14:47 »
Geht denn ein anonymer Mount überhaupt? Oder musst Du da ein Benutzer und Passwort angeben?
« Last Edit: September 13, 2018, 08:19:26 by clausmuus »
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Tommes

  • Newbie
  • *
  • Posts: 12
    • View Profile
[5.4 stable] Rpi3 - CIFS will nicht
« Reply #4 on: September 13, 2018, 18:58:37 »
ja, grundsätzlich kann ich mich da anonym anmelden, habe das im Moment so eingestellt ...
Nur halt mit meinem MLD geht es nicht  :'(
« Last Edit: September 13, 2018, 20:17:43 by Tommes »

Offline Tommes

  • Newbie
  • *
  • Posts: 12
    • View Profile
[5.4 stable] Rpi3 - CIFS will nicht
« Reply #5 on: September 14, 2018, 05:59:34 »
So, ich habe das System jetzt noch mal neu aufgesetzt.
Samba Mount geht auch nicht
'no such device'

Welche Pakete brauche ich denn?
Es gibt 'smbmount', 'cifs' und 'samba'
Bei der letzten Installation habe alle 3 installiert

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
[5.4 stable] Rpi3 - CIFS will nicht
« Reply #6 on: September 14, 2018, 08:12:00 »
samba ist der Server, den brauchst Du nicht. smbmount ist eine Alternative zu cifs
Ich habe das schon lange nicht mehr verwendet, werde aber am Wochenende mal prüfen ob's noch geht, bzw wo's harken kann.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Tommes

  • Newbie
  • *
  • Posts: 12
    • View Profile
[5.4 stable] Rasp Pi 3 - CIFS / Samba mounten
« Reply #7 on: September 17, 2018, 20:13:58 »
Ich habe nochmal einbißchen rumprobiert:
Unter Kodi lassen sich SMB Mounts einbinden, das klappte mit und auch ohne installiertem Paket 'cifs'
Weißt jemand, wie Kodi Samba Freigaben mountet ?

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
[5.4 stable] Rasp Pi 3 - CIFS / Samba mounten
« Reply #8 on: September 17, 2018, 20:33:49 »
Die Funktion ist einkompiliert, und vermutlich kein Mount im klassischen Sinne. Ansonsten müsste "mount" das anzeigen wenn kodi das eingebunden hat.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline Tommes

  • Newbie
  • *
  • Posts: 12
    • View Profile
[5.4 stable] Rasp Pi 3 - CIFS / Samba mounten
« Reply #9 on: September 19, 2018, 18:48:49 »
Also ich hab noch mal ein bisschen geg**gelt.
Für mich sieht es so, dass der Kernel das/die module 'cifs' braucht und er ohne diese kompiliert wurde.
Die Pakete cifs, smbmount und samba bringen die fehlenden Module nicht mit.

Oder liegt das Problem woanders?

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
[5.4 stable] Rasp Pi 3 - CIFS / Samba mounten
« Reply #10 on: September 23, 2018, 21:40:27 »
Danke für den Hinweis. In ein bis zwei Tagen gibt es einen neuen testing Kernel mit dem es wieder klappen sollte.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

[1] MLD-5.x / Systems / Raspberry PI / [5.4 stable] Rasp Pi 3 - CIFS / Samba mounten
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.