[1] MLD-5.x / General / Streamdev Server Keine channels in webif
 

Offline gr4vity

  • Member
  • **
  • Posts: 53
    • View Profile
Streamdev Server Keine channels in webif
« on: January 09, 2018, 16:58:46 »
Hallo,

Please check the attachment.
There are no channels in webif
How to solve that issue?

Best regards
« Last Edit: January 09, 2018, 22:01:58 by gr4vity »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
Streamdev Server Keine channels in webif
« Reply #1 on: January 10, 2018, 11:20:13 »
Is the VDR running at this time?
Do you have try, if it helps to restart the VDR or the PC?
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Member
  • **
  • Posts: 53
    • View Profile
Streamdev Server Keine channels in webif
« Reply #2 on: January 10, 2018, 15:13:55 »
Yes, VDR is running, streamdev server is running as well and i edited svdrphosts.conf to allow streaming on local network.

Streamdev server streaming over VDR and http port 3000 works properly, only problem is there are no channels in webif.

I restart the PC a lot of times since i installed MLD.

Is there anything else i can do?

Best regards.
« Last Edit: January 10, 2018, 15:16:52 by gr4vity »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
Streamdev Server Keine channels in webif
« Reply #3 on: January 10, 2018, 15:58:10 »
May be you have not allow localhost acces in your changed svdrphosts.conf. That is necessary for the webif.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Member
  • **
  • Posts: 53
    • View Profile
Streamdev Server Keine channels in webif
« Reply #4 on: January 10, 2018, 20:50:23 »
Streaming on localhost is allowed by default, i think i know what the problem is.
That screenshot is from Raspberry Pi 3 chromium web browser,
Does it mean that the missing channels will be displayed if i used webif on localhost only?


Offline gr4vity

  • Member
  • **
  • Posts: 53
    • View Profile
Streamdev Server Keine channels in webif
« Reply #5 on: January 13, 2018, 03:22:32 »
The solution to this problem was so easy  :D
I just edited my custom channels.conf and added :-> on the 1st line.
Now all channels are displayed in webif.

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
Streamdev Server Keine channels in webif
« Reply #6 on: January 13, 2018, 10:02:14 »
Thank you for your analysis. I will fix it , so that that line is not necessary.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Member
  • **
  • Posts: 53
    • View Profile
Streamdev Server Keine channels in webif
« Reply #7 on: January 13, 2018, 20:10:33 »
Thank you for your analysis. I will fix it , so that that line is not necessary.

You’re Welcome, thanks in advance for fixing it.

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
Streamdev Server Keine channels in webif
« Reply #8 on: January 15, 2018, 01:23:54 »
it's fixed
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Member
  • **
  • Posts: 53
    • View Profile
Streamdev Server Keine channels in webif
« Reply #9 on: January 15, 2018, 15:17:42 »
Hi Claus,
Are you going to release an updated webif version?

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
Streamdev Server Keine channels in webif
« Reply #10 on: January 15, 2018, 16:45:43 »
it's fixt in the updated package vdr-plugin-streamdev-server.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Member
  • **
  • Posts: 53
    • View Profile
Streamdev Server Keine channels in webif
« Reply #11 on: January 15, 2018, 17:23:04 »
I can't find any updated package  :(
The latest version is :
vdr-plugin-streamdev-server_2017.01.20-19+2.2.0.213.8_amd64.deb

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 16911
    • View Profile
    • ClausMuus.de
Streamdev Server Keine channels in webif
« Reply #12 on: January 15, 2018, 17:30:14 »
I have only fix it for the MLD-5.4
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline gr4vity

  • Member
  • **
  • Posts: 53
    • View Profile
Streamdev Server Keine channels in webif
« Reply #13 on: January 15, 2018, 17:34:20 »
I have only fix it for the MLD-5.4

Oh, Okay .. thank you for fixing it.

[1] MLD-5.x / General / Streamdev Server Keine channels in webif
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.