[1] MLD-5.x / Systems / x86 Systeme (PC) / [gelöst] MLD 5.4 testing, avahi-linker geht nicht nach Update
 

Offline vdr_rossi

  • Member
  • **
  • Posts: 74
    • View Profile
Hallo,

nach dem gestrigen Update läuft avahi-linker nicht mehr.
Beim Start kommt folgende Fehlermeldung
Code: [Select]
vdr1> avahi-linker
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00007fd6dc9d2700 (most recent call first):
Aborted

Danke
« Last Edit: November 16, 2017, 20:33:07 by vdr_rossi »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 15785
    • View Profile
    • ClausMuus.de
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #1 on: November 07, 2017, 23:35:25 »
Hi,

wann hast Du denn zuvor zuletzt aktualisiert? Am avahi-linker Paket wurde schon seit Monaten nichts mehr geändert...

Claus
MLD 2.0 - lirc serial - PSoneTFT - DVB-s-FF & DVB-s-Budget - Medion 2001 mit AMD 450 - 256MB RAM - 1TB HDD
MLD 2.0 - SMT-7020s - 80GB HDD
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559

Offline vdr_rossi

  • Member
  • **
  • Posts: 74
    • View Profile
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #2 on: November 08, 2017, 13:47:18 »
Mahlzeit,

vor dem "großen" Update, es wurden alle Pakete aktualisiert - das habe ich Montag Abend gemacht.
Mein x64 System ist auf 5.4 testing

Danke

Offline vdr_rossi

  • Member
  • **
  • Posts: 74
    • View Profile
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #3 on: November 13, 2017, 13:36:22 »
Hallo,

wenn ich die Fehlermeldungen richtig deute, fehlen da doch libraries ?
Würde mich über eine Reparatur des Paketes sehr freuen.

Danke

Offline skippy

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 1989
    • View Profile
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #4 on: November 13, 2017, 18:23:55 »
Hallo vdr_rossi,

auch wenn dir das jetzt nicht viel hilft, nach dem letzten großen Update läuft mein avahi-linker gewohnt stabil, sowohl auf einem RPi3, als auch auf einem x64-System - jeweils MLD 5.4 testing. Der avahi-linker ist in der Version 16031-32.5 drauf. Hier noch die Python-Pakete vom x86-Sytstem, weil Python bei dir gemeckert hat:
Code: [Select]
python 2.7-12
python3 3.5-2
python3-avahi 3.5-0
python3-dbus 1.2.4-0
python3-gi 3.24.1-0

Hiervon abweichen ist auf dem RPi3 python3-gi in der Version 3.22.0-0

Viele Grüße skippy
meine MLDs (show / hide)

Offline vdr_rossi

  • Member
  • **
  • Posts: 74
    • View Profile
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #5 on: November 13, 2017, 19:44:09 »
Danke für die Rückmeldung.

Habe eben nochmal die Pakete avahi-linker, python3 und python deinstalliert und danach neu installiert.
Keine Veränderung.

Offline TVman

  • Newbie
  • *
  • Posts: 2
    • View Profile
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #6 on: November 15, 2017, 06:34:40 »
Hallo MLD-Team und Fans,
erstmal danke an alle für die super MLD-Distribution. Ich habe mittlerweile 4 Stück x86 Systeme mit MLD5.3stable am laufen, da funktioniert alles.
Leider kann ich bestätigen, dass bei meinem Test-VDR-System (auch ein x86 System) mit MLD5.4testing der avahi-linker nicht funktioniert. Installiert habe ich am letzten Sonntag,  12.11.2017 mit dem "MLD-5.4_netinstall_2017.11.11-178.17+1612_amd64.img".

Gruß
Olli

Offline strike

  • Newbie
  • *
  • Posts: 29
    • View Profile
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #7 on: November 15, 2017, 09:26:19 »
Hallo,

Habe heute ein Update durchgeführt. Leider bei mir das gleiche Problem.

Code: [Select]
MLD> avahi-linker
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Fatal Python error: Py_Initialize: Unable to get the locale encoding
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00007fbec2feb700 (most recent call first):
Aborted

Gruß,
 strike
VDR1: Asrock H61M-US3S, NVIDIA GT630, 1x Cine S2 Rev 7.0A mit Duoflex, 1x Duoflex CI, MLD 5.4 unstable
VDR2: M4N78Pro, Asus1GB EN GT520 SILENT, 1x Cine S2 Rev 5.5, MLD 5.4 testing
VDR3: Raspi2 mit MLD-5

Online rfehr

  • MLD-Developer
  • Expert Member
  • ******
  • Posts: 685
    • View Profile
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #8 on: November 15, 2017, 23:44:00 »
Hi Zusammen,
 
Debug-Log wäre interessant.

Gruß,
  Roland
1x OctopusNet mit 2x DVB-S2 u. 2x DVB-C
1x Zotac ITX-A Atom 330 als Client
1x RPI2 als Client
1x Cubietruck
1x BananaPi
1x Wetekplay
1x MCC 100
1x RPI3

Online MegaX

  • Administrator
  • Expert Member
  • ********
  • Posts: 1810
    • View Profile
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #9 on: November 16, 2017, 13:26:30 »
Hi,

Debug-Log ist nicht mehr nötig, denn mit dem heutigen Update sollte der Fehler behoben sein.

Gruß MegaX

Hardware (show / hide)

Offline TVman

  • Newbie
  • *
  • Posts: 2
    • View Profile
MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #10 on: November 16, 2017, 17:54:10 »
Hallo Zusammen,
ja, funktioniert wieder  :D.

Danke!

Gruß
Olli

Offline vdr_rossi

  • Member
  • **
  • Posts: 74
    • View Profile
[gelöst] MLD 5.4 testing, avahi-linker geht nicht nach Update
« Reply #11 on: November 16, 2017, 20:33:40 »
Alles klar, avahi-linker läuft wieder.

Danke!

[1] MLD-5.x / Systems / x86 Systeme (PC) / [gelöst] MLD 5.4 testing, avahi-linker geht nicht nach Update
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.