[1] MLD-5.x / Systems / Raspberry PI / Rpi3 MLD5.4 unstable kein Bluethooth Paket
 

Offline mafe68

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2167
  • Immer auf der Suche nach was neuem!
    • View Profile
    • Mediastreambox
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« on: September 10, 2017, 16:45:14 »
Wollte das Bluetooth Paket installieren weil wir im letzten VC gesprochen haben das es jetzt auch funktioniert. Das ich es testen kann ob man einen Bluetooth Lautsprecher einbinden kann. Nur es gibt das Bluetooth Paket zur Zeit nicht.
Gruß Mario
Meine Hardware (show / hide)

Offline mafe68

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2167
  • Immer auf der Suche nach was neuem!
    • View Profile
    • Mediastreambox
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #1 on: September 10, 2017, 16:49:23 »
Sorry über das WebIf ist es nicht dabei aber über das Terminal konnte ich es installieren. Weitere Test kommen noch :)
Gruß Mario
Meine Hardware (show / hide)

Offline mafe68

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2167
  • Immer auf der Suche nach was neuem!
    • View Profile
    • Mediastreambox
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #2 on: September 10, 2017, 17:50:04 »
So habe die ersten Test gemacht um zu versuchen einen Bluetooth Lautsprecher zu verbinden, nur bringe ich keine Verbindung zusammen.
Hier die Ausgaben im Terminal:
Code: [Select]
MLD> bluetoothctl
[NEW] Controller AA:AA:AA:AA:AA:AA BlueZ 5.43 [default]
[bluetooth]# agent on
Agent registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# scan on
Discovery started
[bluetooth]#
Die MAC Adresse des Controller kommt mir auch ein wenig komisch vor. Gibt es so eine Adresse? Wird aber immer wieder dir selbe angezeigt.
Beim Scan findest er kein Gerät das aber daneben steht und eingeschaltet ist.
Gruß Mario
Meine Hardware (show / hide)

Offline mafe68

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2167
  • Immer auf der Suche nach was neuem!
    • View Profile
    • Mediastreambox
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #3 on: September 11, 2017, 09:37:40 »
Habe gerade beim Einschalten des Rpi in der /var/log/sysinit folgende Meldung gesehen. Kann das mit der komischen MAC Adresse zu tun haben die angezeigt wird?
Code: [Select]
Starting bluetoothd:
Patch not found for BCM43430A1, continue anyway
bcm43xx_init
Set Controller UART speed to 921600 bit/s
Device setup complete
Failed to write reset command
Can't initialize device: Success
bcm43xx_init
failed
Gruß Mario
Meine Hardware (show / hide)

Offline NemoN

  • Newbie
  • *
  • Posts: 40
    • View Profile
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #4 on: September 05, 2018, 13:46:58 »
Ausgabe bluetoothctl:
Code: [Select]
[NEW] Controller AA:AA:AA:AA:AA:AA BlueZ 5.43 [default]

Es fehlt die Firmware für das Bluetooth Modul.
@Claus: vielleicht kann diese mit in das Bluetooth Paket gepackt werden.
Diese kann man wie folgt installieren:

Code: [Select]
mkdir -p /lib/firmware/brcm
cd /lib/firmware/brcm
wget https://github.com/OpenELEC/misc-firmware/raw/master/firmware/brcm/BCM43430A1.hcd
reboot

Ausgabe bluetoothctl:
Code: [Select]
[NEW] Controller B8:27:EB:06:XX:XX BlueZ 5.43 [default]
« Last Edit: September 05, 2018, 13:53:54 by NemoN »

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17490
    • View Profile
    • ClausMuus.de
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #5 on: September 05, 2018, 13:52:40 »
Danke für den Hinweis.
Ich denke in Deiner Beschreibung fehlt nach den "mkdir ..." fehlt noch ein "cd /lib/firmware/brcm"?
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline NemoN

  • Newbie
  • *
  • Posts: 40
    • View Profile
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #6 on: September 05, 2018, 13:54:18 »
Danke für den Hinweis.
Ich denke in Deiner Beschreibung fehlt nach den "mkdir ..." fehlt noch ein "cd /lib/firmware/brcm"?

angepasst :-)

Offline BlueVIP

  • Newbie
  • *
  • Posts: 4
    • View Profile
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #7 on: February 09, 2019, 09:17:40 »
Moin,

versuche gerade einen Bluetooth-Kopfhörer mit meinem RPI 3B+ (MLD5.4 testing) zu pairen, allerdings schlägt bereits die Installation des Pakets "bluetooth" fehl:
Code: [Select]
MLD> apt-get install bluetooth
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 bluetooth:armhf-rpi2 : Depends: kernel:armhf-rpi2 (>= 4.16.18.201.3) but 4.16.18.201-201 is to be installed
E: Unable to correct problems, you have held broken packages.

Jemand eine Idee?

Grüße
BlueVIP

Online clausmuus

  • Administrator
  • Expert Member
  • ********
  • Posts: 17490
    • View Profile
    • ClausMuus.de
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #8 on: February 09, 2019, 10:01:05 »
Wechsel mal auf stable oder unstable, dann sollte das gehen. Oder warte zwei Tage, dann gibt's nen update des testing.
MLD 5.1 - Raspberry PI - 7" Touch TFT - Squeeze Play
MLD 5.1 - lirc yaUsbIR - OctopusNet - XFX GeForce 9300 mit Intel E3200 - 2GB RAM - 6TB HDD - Lian Li PC-C37B - Samsung LE40A559
MLD 5.4 - OctopusNet - ASRock Q1900M - 2GB RAM 250GB HDD

Offline BlueVIP

  • Newbie
  • *
  • Posts: 4
    • View Profile
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #9 on: February 09, 2019, 10:09:17 »
Moin Klaus,

danke für die rasche Antwort. Ich warte dann mal lieber 2 Tage ;)
Beim Wechseln (stable -> testing) lief mir bereits ein Schauer den Rücken runter  ;D

Offline mafe68

  • MLD-Tester
  • Expert Member
  • ******
  • Posts: 2167
  • Immer auf der Suche nach was neuem!
    • View Profile
    • Mediastreambox
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #10 on: February 10, 2019, 05:56:51 »
Da braucht dir kein Schauer über den Rücken laufen , wenn was nicht passt einfach per Snapshot zurück gehen und schon passt es wieder. Es  wird bei jedem Update oder wenn du von Stable auf Testing gehst einer erstellt bevor das Update u.s.w gemacht wird. Da geschieht alles automatisch.
Gruß Mario
Meine Hardware (show / hide)

Offline baltic

  • Profi Member
  • ****
  • Posts: 307
    • View Profile
Rpi3 MLD5.4 unstable kein Bluethooth Paket
« Reply #11 on: February 10, 2019, 19:25:31 »
Räusper, räusper.....   ;)
MLD 5.4 – testing   Asus M3N78-EM  SkyStar2

[1] MLD-5.x / Systems / Raspberry PI / Rpi3 MLD5.4 unstable kein Bluethooth Paket
 



Users Online Users Online

0 Members and 1 Guest are viewing this topic.